数据结构与算法题目集(中文)7-52 两个有序链表序列的交集 (20分)

1.题目

已知两个非降序链表序列S1与S2,设计函数构造出S1与S2的交集新链表S3。

输入格式:

输入分两行,分别在每行给出由若干个正整数构成的非降序序列,用−1表示序列的结尾(−1不属于这个序列)。数字用空格间隔。

输出格式:

在一行中输出两个输入序列的交集序列,数字间用空格分开,结尾不能有多余空格;若新链表为空,输出NULL

输入样例:

1 2 5 -1
2 4 5 8 10 -1

输出样例:

2 5

2.代码

 

#include<iostream>
#include<list>
using namespace std;
int main()
{
	list<int>t1;
	list<int>t2;
	while(1)
	{
		int temp;
		cin >> temp;
		if (temp == -1)
			break;
			t1.push_back(temp);
	}
	while (1)
	{
		int temp;
		cin >> temp;
		if (temp == -1)
			break;
			t2.push_back(temp);
	}
	if (t1.empty() || t2.empty())
		cout << "NULL" << endl;
	else
	{
		t1.merge(t2);
		int count = 0;
		while (!t1.empty())
		{
			int out = t1.front();
			int out2 = -1;
			t1.pop_front();
			if (!t1.empty())
				out2 = t1.front();
			if (out == out2)
			{
				if (count == 0)
				{
					cout << out;
					count++;
				}
				else
					cout << " " << out;
			}
		}//while
		if (count == 0)
			cout << "NULL" << endl;
	}//else
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值