You are to determine the value of the leaf node in a given binary tree that is the terminal node of a path of least value from the root of the binary tree to any leaf. The value of a path is the sum of values of nodes along that path. Input The input file will contain a description of the binary tree given as the inorder and postorder traversal sequences of that tree. Your program will read two line (until end of file) from the input file. The first line will contain the sequence of values associated with an inorder traversal of the tree and the second line will contain the sequence of values associated with a postorder traversal of the tree. All values will be different, greater than zero and less than 10000. You may assume that no binary tree will have more than 10000 nodes or less than 1 node. Output For each tree description you should output the value of the leaf node of a path of least value. In the case of multiple paths of least value you should pick the one with the least value on the terminal node.
Sample Input
3 2 1 4 5 7 6
3 1 2 5 6 7 4
7 8 11 3 5 16 12 18
8 3 11 7 16 18 12 5
255
255
Sample Output
1
3
255
题意根据输入的中序遍历和后序遍历输出某节点到其他节点权和最小的值
使用链表建树以及dfs深搜;
代码如下
#include<iostream>
#include<string>
#include<sstream>
#include<algorithm>
using namespace std;
const int maxn=10000+5;
int in_order[maxn],post_order[maxn],lchild[maxn],rchild[maxn];
int n;
bool read_list(int*a)
{
string sstr;
if(!getline(cin,sstr)) return false;
stringstream ss(sstr);
n=0;
int x;
while(ss>>x)
a[n++]=x;
return true;
}
int build(int l1,int r1,int l2,int r2)
{
if(l1>r1) return 0;
int root=post_order[r2];
int p=l1;
while(in_order[p]!=root) p++;
int cnt=p-l1;
lchild[root]=build(l1,p-1,l2,l2+cnt-1);
rchild[root]=build(p+1,r1,l2+cnt,r2-1);
return root;
}
int best,best_sum;
void dfs(int dep,int sum)
{
sum+=dep;
if(sum>best_sum)
return;
if(!lchild[dep]&&!rchild[dep]){
if(sum<best_sum||(sum==best_sum&&dep<best))
{
best=dep;
best_sum=sum;
}
}
if(lchild[dep]) dfs(lchild[dep],sum);
if(rchild[dep]) dfs(rchild[dep],sum);
}
int main()
{
while(read_list(in_order))
{
read_list(post_order);
build(0,n-1,0,n-1);
best_sum=10000000;
dfs(post_order[n-1],0);
cout<<best<<endl;
}
return 0;
}