PAT Advanced—1011 World Cup Betting (20分)

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.
Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results – namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.
For example, 3 games’ odds are given as the following:
W T L
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).
Input Specification:
Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.
Output Specification:
For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1
Sample Output:
T T W 39.31

思路:
  主要是弄清题意,就是有三次打赌,每一次总有一个选项的赔率最高,按顺序输出每一次的那个选项赔率最高,然后根据公式输出该情况下最大收益
反正题目只规定了3次,为了简便一次一次运算比较即可

注意:

  1. 代码可以进行很大的优化,可以用scanf()一次输入一次游戏的情况,这样只需一个3次循环即可输出所有数据,并直接判断每一次游戏的最大情况
  2. 三个数的比较可以用max(max(w,t),l)这种方式实现

代码:(C++)

#include<iostream>

using namespace std;

double odds[9];

int main()
{
    int a[3]; //保存最高赔率对应号码
    for(int i=0; i<9; i++)
        cin>>odds[i];

    double max_s = -1;
    for(int i=0; i<3; i++)
    {
        if(odds[i]>max_s)
        {
            max_s = odds[i];
            a[0] = i;
        }
    }
    max_s = -1;
    for(int i=3; i<6; i++)
    {
        if(odds[i]>max_s)
        {
            max_s = odds[i];
            a[1] = i;
        }
    }
    max_s = -1;
    for(int i=6; i<9; i++)
    {
        if(odds[i]>max_s)
        {
            max_s = odds[i];
            a[2] = i;
        }
    }
    char b[] = {'W', 'T', 'L'};
    for(int i=0; i<3; i++)
    {
        cout<<b[a[i]%3]<<" ";
    }
    printf("%0.2f", (odds[a[0]]*odds[a[1]]*odds[a[2]]*0.65-1)*2);
    
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值