PAT Advanced—1004 Counting Leaves (30分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.
The input ends with N being 0. That case must NOT be processed.
Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:
2 1
01 1 02
Sample Output:
0 1

思路:
  先构造完整的树,再对树进行遍历,从而确定每层的叶子结点数目

注意:

  1. 这题结点输入的顺序不一定是按照从根结点向下输入的,所以需要等到所有结点的信息都输入完毕了,才能统计层数
  2. 想给结构体中非静态成员赋默认值,只能在C++11中实现

代码:(C++)
  稍微改造了一下前面的代码,也是通过遍历来做,只是在记录层数的时候,用到了BFS来计算每个结点所在的层数。

#include<iostream>
#include<map>
#include<queue>

using namespace std;

struct node
{
	int id;
	int father;
	int level;
	int childNum;
};

int level[100] = {0};  //保存每层的叶子结点数

int main()
{
	int n,m;
	cin>>n>>m;
	map<int,node> tree;
	tree[1].id = 1;
	tree[1].level = 1;
	tree[1].father = -1;
	int max_level = 1;
	for(int i=0; i<m; i++)
	{
		int p,k;
		cin>>p>>k;
		tree[p].childNum = k;  //此处记录了父节点中子节点个数
		for(int j=0; j<k; j++)
		{
			int childId;
			cin>>childId;
			if(tree.find(childId) == tree.end()) //没有的则初始化
				tree[childId].childNum = 0;
			tree[childId].id = childId;
			tree[childId].father = p;
		}
	}
	queue<node> que;
	que.push(tree[1]);
	while(!que.empty())
	{
		node nd = que.front();
		que.pop();
		if(nd.childNum == 0) //由于每个结点只会出来一次,直接在这个保存就可
			level[nd.level]++;
		for(map<int,node>::iterator it=tree.begin(); it!=tree.end(); it++)
		{
			if(it->second.father == nd.id)
			{
				it->second.level = nd.level + 1;
				max_level = max(max_level, it->second.level);
				que.push(it->second);
			}
		}
	}
	for(int i=1; i<=max_level; i++)
	{
		printf("%d", level[i]);
		if(i != max_level)
			cout<<" ";
	}
	return 0;
}

有问题的思路:
  由于本道题的数据量不大,想到直接遍历寻找每一层的叶子结点数目。用map保存结点名称,后输入的结点只需要按照父节点层数加1即可,由于根结点层数为1,按照从根结点往下输入,就可以得知每个结点的层数了。最后没输出一层,遍历map即可。

未通过测试点:
在这里插入图片描述

分析:
  可能是非叶子结点的输入顺序,没有按照从根往下的顺序输入,导致后面的孩子结点的层数发生错误

代码:(C++) [通过不了]

#include<iostream>
#include<map>

using namespace std;

struct node
{
	int id;
	int childNum;
	int level;
};

int main()
{
	int n,m;
	cin>>n>>m;
	node root;
	root.id = 1;
	root.level = 1;
	root.childNum = 0;
	map<int,node> tree;
	tree[1] = root;
	int max_level = 1;
	for(int i=0; i<m; i++)
	{
		int p,k;
		cin>>p>>k;
		tree[p].childNum += k;  //此处记录了父节点中子节点个数
		for(int j=0; j<k; j++)
		{
			node child;
			cin>>child.id;
			child.level = tree[p].level + 1;
			child.childNum = 0;
			max_level = max(max_level, child.level);
			tree[child.id] = child;
		}
	}
	for(int i=1; i<=max_level; i++)
	{
		int num = 0;
		for(map<int,node>::iterator it=tree.begin(); it!=tree.end(); it++)
		{
			if(it->second.level == i && it->second.childNum == 0)
				num++;
		}
		printf("%d", num);
		if(i != max_level)
			cout<<" ";
	}
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值