PAT Advanced—1155 Heap Paths (30分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))
One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.
Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.
Output Specification:
For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.
Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.
Sample Input 1:
8
98 72 86 60 65 12 23 50
Sample Output 1:
98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:
8
8 38 25 58 52 82 70 60
Sample Output 2:
8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:
8
10 28 15 12 34 9 8 56
Sample Output 3:
10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

题目大意:
  以完全二叉树层次遍历的顺序输入结点key,按从根到叶子输出结点值并按总右子树到左子树的顺序,最后判断是大根堆还是小根堆或者不是堆。

思路:

  1. 将这些结点按顺序存储,构建的时候查找
  2. 完全二叉树寻找孩子结点可用,左2x,右2x+1
  3. 主要用到深度优先遍历

注意:

  1. 深搜有一个回退过程,要记住模板

代码:(C++)

#include<iostream>
#include<vector>

using namespace std;

int a[1009] = {0};
int n, isMax=1, isMin=1;
vector<int> v;


void dfs(int index)
{
	if(index*2>n && index*2+1>n)  //无左右子树的结点,为叶子结点
	{
		if(index<=n)  //这个主要用于判断这个结点是否是树的叶子结点
		{
			for(int i=0; i<v.size(); i++)
			{
				//这个打印方便
				printf("%d%s", v[i], i != v.size()-1? " ": "\n");
			}
		}
	}
	else
	{
		v.push_back(a[index*2+1]); //记录右节点
		dfs(index*2+1);//对右子树进行遍历
		v.pop_back(); //遍历完了之后弹出刚刚放进去的结点
		v.push_back(a[index*2]); //左节点
		dfs(index*2);
		v.pop_back();
	}
}

int main()
{
	cin>>n;
	for(int i=1; i<=n; i++)
		scanf("%d",&a[i]);
	v.push_back(a[1]);  //根结点每条路径里面都有
	dfs(1);
	for(int i=2; i<=n; i++)
	{
		//对于每个结点都可以比较它与父节点的大小关系
		if(a[i/2] > a[i]) isMin = 0;
		if(a[i/2] < a[i]) isMax = 0;
	}
	if(isMin == 1)
		printf("Min Heap");
	else
		printf("%s", isMax == 1 ? "Max Heap" : "Not Heap"); //一行里面输出,减少代码量
	
	return 0;
}

参考:
  https://blog.csdn.net/liuchuo/article/details/84973009

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值