PAT甲级-1018-Public Bike Management(迪杰斯特拉算法+dfs)

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.
在这里插入图片描述
The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S​3 , we have 2 different shortest paths:

1.PBMC -> S​1​​  -> S​3​​ . In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S​1and then take 5 bikes to S​3 , so that both stations will be in perfect conditions.

2.PBMC -> S2​​  -> S​3. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.
Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: C​max(≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; S
​p, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers Ci (i=1,⋯,N) where each C​i is the current number of bikes at Si respectively. Then M lines follow, each contains numbers: S​i, Sj, and Tij which describe the time Tij taken to move betwen stations S​iand Sj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S1 −>⋯−>S​p . Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S​p is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge’s data guarantee that such a path is unique.

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0

思路:

1、先利用Dijkstra算法找到最短路,并将最短路中每一顶点的前驱结点保存至pre中。
注意:前驱结点可能不唯一!最短路可能不唯一!
2、然后再利用dfs深搜遍历pre(最短路),在遍历最短路过程中,调整每个站点的单车容量,并按照从PBMC取出、收回至PBMC的单车数结合题目所给优先级,将路径将入到结果vector中。
注:由于本题是按照前驱结点回推的,因此路径输出时应该倒序输出!

1、Dijkstra算法

此处是Dijkstra算法详解,可参考

for(int i = 0; i <= n; i++)
	{
		int min = INT_MAX,index = -1;
		for(int j = 0; j <= n; j++)
		{
			if(!visit[j] && dis[j]<min){
				min = dis[j];
				index = j;
			}
		} 
		if(index == -1) break;
		visit[index] = 1;
		
		for(int j = 0; j <= n; j++)
		{
			if(!visit[j] && map[index][j] != INT_MAX){
				if(dis[j] > dis[index]+map[index][j]){//说明一点,index(顶点2)的加入缩短了路径哦! 
					dis[j] = dis[index]+map[index][j];
					pre[j].clear();
					pre[j].push_back(index);
				}else if(dis[j] == dis[index]+map[index][j]){
					pre[j].push_back(index);
				}
			}
		} 
	}

2、dfs

一、adjust调整

将每个顶点的值与profect(即最大可容纳自行车数的一半)进行比较:
顶点值 > profect:收回PBMC(back++
顶点值 < profect:

判断back中值是否可供补充顶点值
    back还可用:back- -
    back用完,PBMC自己产:send- -,back=0
二、按照send、back优先级更新值与vector

本题中,优先级send > back,按照优先级更新minSend,minBack , 并更新结果容器path。

void dfs(int v)
{
	tempPath.push_back(v);
	if(v == 0)//递归出口 
	{
		int send=0,back=0,profect=cmax/2;
		for(int i = tempPath.size()-2; i >= 0; i--)
		{
			int id = tempPath[i];
			if(weigh[id] > profect){
				back += (weigh[id]-profect);
			}else if(weigh[id] < profect){
				if(back > profect-weigh[id]){
					back -= (profect-weigh[id]);
				}else{
					send += (profect-weigh[id])-back;
					back = 0;
				}
			}
		}
		
		//这里就要按照优先级分配了!(send>back) 
		if(send < minSend)
		{
			minSend = send;
			minBack = back;
			path = tempPath;
		}else if(send == minSend && back < minBack){
			minBack = back;
			path = tempPath;
		}
		tempPath.pop_back();
		return;
	}
	//递归体 
	for(int i = 0; i < (int)pre[v].size(); i++)
	{
		dfs(pre[v][i]);
	}
	tempPath.pop_back();
}

3.完整代码

#include<iostream>
#include<climits>
#include<vector>
using namespace std;

const int N = 505;
int n;
int map[N][N];
int visit[N],dis[N],weigh[N];
int minSend=INT_MAX,minBack=INT_MAX;
int cmax;//最大容量 

vector<int> tempPath,path,pre[N];

void dfs(int v)
{
	tempPath.push_back(v);
	if(v == 0)//递归出口 
	{
		int send=0,back=0,profect=cmax/2;
		for(int i = tempPath.size()-2; i >= 0; i--)
		{
			int id = tempPath[i];
			if(weigh[id] > profect){
				back += (weigh[id]-profect);
			}else if(weigh[id] < profect){
				if(back > profect-weigh[id]){
					back -= (profect-weigh[id]);
				}else{
					send += (profect-weigh[id])-back;
					back = 0;
				}
			}
		}
		
		//这里就要按照优先级分配了!(send>back) 
		if(send < minSend)
		{
			minSend = send;
			minBack = back;
			path = tempPath;
		}else if(send == minSend && back < minBack){
			minBack = back;
			path = tempPath;
		}
		tempPath.pop_back();
		return;
	}
	//递归体 
	for(int i = 0; i < (int)pre[v].size(); i++)
	{
		dfs(pre[v][i]);
	}
	tempPath.pop_back();
}
int main()
{
	int m,sp;
	cin>>cmax>>n>>sp>>m;
	
	int tmp;int x,y,d;
	fill(map[0],map[0]+N*N,INT_MAX);
  	fill(dis,dis+N,INT_MAX);
  	fill(visit,visit+N,0);
	for(int i = 1; i <= n; i++)
	{
		cin>>tmp;
		weigh[i] = tmp;
	}
	for(int i = 0; i < m; i++)
	{
		cin>>x>>y>>d;
		map[x][y] = map[y][x] = d;	
	}
	
	dis[0] = 0;
	for(int i = 0; i <= n; i++)
	{
		int min = INT_MAX,index = -1;
		for(int j = 0; j <= n; j++)
		{
			if(!visit[j] && dis[j]<min){
				min = dis[j];
				index = j;
			}
		} 
		if(index == -1) break;
		visit[index] = 1;
		
		for(int j = 0; j <= n; j++)
		{
			if(!visit[j] && map[index][j] != INT_MAX){
				if(dis[j] > dis[index]+map[index][j]){//说明一点,index(顶点2)的加入缩短了路径哦! 
					dis[j] = dis[index]+map[index][j];
					pre[j].clear();
					pre[j].push_back(index);
				}else if(dis[j] == dis[index]+map[index][j]){
					pre[j].push_back(index);
				}
			}
		} 
	}
	
	dfs(sp);
	cout<<minSend<<" ";
	for(int i = path.size()-1; i > 0; i--)
	{
		cout<<path[i]<<"->";//有非常坑的一点,最后一个->多余了! 
	}
	cout<<path[0]<<" "<<minBack;
	
	return 0;
}
  • 5
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值