1018 Public Bike Management

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S3​, we have 2 different shortest paths:

  1. PBMC -> S1​ -> S3​. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S1​ and then take 5 bikes to S3​, so that both stations will be in perfect conditions.

  2. PBMC -> S2​ -> S3​. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

总结:各个站点要达到半满状态 ,时间要短

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: Cmax​ (≤100), always an even number, is the maximum capacity of each stationN (≤500), the total number of stationsSp​, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers Ci​ (i=1,⋯,N) where each Ci​ is the current number of bikes at Si​ respectively.(现在各点的单车数量) Then M lines follow, each contains 3 numbers: Si​, Sj​, and Tij​ which describe the time Tij​ taken to move betwen stations Si​ and Sj​. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S1​−>⋯−>Sp​. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of Sp​ is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

输出:送入单车数 路径 拿走的单车数

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0
#include<iostream>
#include<vector>

using namespace std;

void dfs(int curstation,int curdis,int cursend,int curtake);
int Cmax,N,Sp,M;
int bike[501],dis[501][501],mindis_to[501];
vector<int>v[501];
vector<int>path;
//用path记录单次的路径点 
int final_dis=99999,final_send,final_take;
vector<int>final_ans;
//用final_ans记录完整路径 
void dfs(int curstation,int curdis,int cursend,int curtake)
{	if(curdis>mindis_to[curstation])return;
	path.emplace_back(curstation);
	if(curstation==Sp){
		//到达问题车站Sp 
		if(curdis<final_dis||(curdis==final_dis&&cursend<final_send)||(curdis==final_dis&&cursend==final_send&&curtake<final_take))
		{    //记录数据
			final_ans=path;
			final_dis=curdis;
			final_take=curtake;
			final_send=cursend;
		}
	}
	else{
		//未到达的则继续dfs 
		if(curdis<mindis_to[curstation])mindis_to[curstation]=curdis;//更新最短路径 
		for(int i:v[curstation]){
			//遍历curstation的邻居 
			if(curtake+bike[i]<Cmax/2){
				//上一个点拿的加上该点的数量达不到半满 ,所以需要多带点单车来(需要带的加上半满与curtake和当前站点单车数量之差),但不需要送出单车 
				dfs(i,curdis+dis[curstation][i],cursend+Cmax/2-curtake-bike[i],0);
			}
			else{
				//超过半满, 送出多出的部分
				dfs(i,curdis+dis[curstation][i],cursend,curtake+bike[i]-Cmax/2);
			}
		}
	}
	path.pop_back();
}



int main(){	
int i,j,k;
	cin>>Cmax>>N>>Sp>>M;
	for(i=1;i<=N;i++)cin>>bike[i];
	while(M--){
		cin>>i>>j>>k;
		v[i].emplace_back(j);
		v[j].emplace_back(i);
		dis[i][j]=dis[j][i]=k;
	}
	//输入	
	for(i=0;i<=N;i++)mindis_to[i]=999999;
		dfs(0,0,0,0);
		//深度优先搜索 
		cout<<final_send<<' ';
		cout<<final_ans[0];
		for(i=1;i<final_ans.size();i++){
			cout<<"->"<<final_ans[i];
		}
		cout<<' '<<final_take;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值