PAT甲级-1102-Invert a Binary Tree(反转二叉树+中序+层序遍历)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

__ Now it’s your turn to prove that YOU CAN invert a binary tree!__

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.__

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

层序遍历代码:
bool cmp(node a,node b){
	if(a.level != b.level) return a.level< b.level;
	return a.index > b.index;
}

代码如下

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int n;
struct node{
	int id,left,right,index,level;
}arr[15];
vector<node> v1;
bool cmp(node a,node b){
	if(a.level != b.level) return a.level< b.level;
	return a.index > b.index;
}
void travel(int root,int index,int level)
{
	if(arr[root].right!=-1)travel(arr[root].right, 2*index+2, level+1);
	v1.push_back({root,0,0,index,level});
	if(arr[root].left!=-1)travel(arr[root].left, 2*index+1, level+1);
}
int main()
{
	cin>>n;int root = 0,flag[15]={0};string l,r;
	for(int i = 0; i < n; i++){
		arr[i].id= i;
		cin>>l>>r;
		if(l != "-") {
			arr[i].left = stoi(l);flag[stoi(l)] = 1;
		}else{
			arr[i].left = -1;
		};
		if(r != "-") {
			arr[i].right = stoi(r);flag[stoi(r)] = 1;
		}else{
			arr[i].right = -1;
		};
	}
	while(flag[root] == 1) root++;
	travel(root,0,0);
	vector<node> v2(v1);
	sort(v2.begin(),v2.end(),cmp);
	for(int i = 0; i < v2.size()-1; i++){
		cout<<v2[i].id<<" ";
	}
	cout<<v2[v2.size()-1].id<<endl; 
	for(int i = 0; i < v1.size()-1; i++){
		cout<<v1[i].id<<" ";
	}
	cout<<v1[v1.size()-1].id;
	return 0;
}
  • 5
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值