PAT甲级-1037-Magic Coupon(贪心)

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​ , followed by a line with N​C coupon integers. Then the next line contains the number of products NP, followed by a line with N​P product values. Here 1≤N​C ,N​P≤105, and it is guaranteed that all the numbers will not exceed 2​30
.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:
4
1 2 4 -1
4
7 6 -2 -3

Sample Output:
43

代码如下

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int main()
{
	int nc,np,ans = 0;
	cin>>nc;
	vector<int> v1(nc);
	for(int i = 0; i < nc; i++){
		scanf("%d", &v1[i]);
	} 
	cin>>np;
	vector<int> v2(np);
	for(int i = 0; i < np; i++){
		scanf("%d", &v2[i]);
	} 
	sort(v1.begin(), v1.end());
	sort(v2.begin(), v2.end());
	for(int i = v1.size()-1,j = v2.size()-1; i>=0&&j>=0;i--,j--){
		if(v1[i]>0&&v2[j]>0){
			ans += v1[i]*v2[j];
		}else{
			break;
		}
	}
	for(int i = 0,j = 0; i<v1.size()&&j<v2.size();i++,j++){
		if(v1[i]<0&&v2[j]<0){
			ans += v1[i]*v2[j];
		}else{
			break;
		}
	}
	cout<<ans<<endl;
	return 0;
}
  • 4
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值