Fire Net JAVA版

Fire Net

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16825 Accepted Submission(s): 10228

Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a ‘.’ indicating an open space and an uppercase ‘X’ indicating a wall. There are no spaces in the input file.

Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample Input
4
.X…

XX…

2
XX
.X
3
.X.
X.X
.X.
3

.XX
.XX
4




0

Sample Output
5
1
5
2
4

HDU 1045
java代码如下,从大佬的代码改的,仅供参考:

package dfs;

import java.util.Scanner;

/*
 * 1.寻找最优解问题;
 * 2.从第一格遍历,如果不是墙并且同行伙同列中没有冲突,则能放,记录个数(搜到底进行比较),然后标记此格向下搜索*/
public class P_1045_1 {
	static int n,i,j,ans;
	static char[][] s=new char[5][5];
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner sc=new Scanner(System.in);
		while(sc.hasNext()) {
			n=sc.nextInt();
			if(n==0)break;
			ans=0;
			for(int i=0;i<n;i++) {
				String str=sc.next();
				s[i]=str.toCharArray();
			}
			dfs(0,0);
			System.out.println(ans);
		}

	}
	private static void dfs(int k, int l) {
		// TODO Auto-generated method stub
		int x=0,y=0;
		if(k==n*n) {    //如果搜索到最后1格
			if(l>ans)     //比较放置个数
				ans=l;
			return;
		}else {
			x=k/n;    //行数
			y=k%n;     //列数
			//如果单元格可以放置
			if(s[x][y]=='.'&&c_put(x,y)) {  //判断是否为碉堡,是否产生冲突
				s[x][y]='O';    //防止碉堡,并且标记
				dfs(k+1,l+1);
				s[x][y]='.';
			}
			//如果单元格不可以放置
			dfs(k+1,l); //否则就向下继续寻找
		}
		
	}
	private static boolean c_put(int n, int m) {
		// TODO Auto-generated method stub
		for(int i=n-1;i>=0;i--) {     //行数 向前寻找
			if(s[i][m]=='O')    //如果有碉堡则产生冲突
				return false;
			if(s[i][m]=='X')    //如果在遇到碉堡之前遇到了墙壁 则可以放 直接跳出循环
				break;
		}
		for(int j=m-1;j>=0;j--) {    //列数,向前寻找
			if(s[n][j]=='O')  //如果有碉堡则产生冲突
				return false;
			if(s[n][j]=='X')    //如果在遇到碉堡之前遇到了墙壁则可以放,直接跳出循环
				break;
		}
		return true;
	}

}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值