hdu6222 Heron and His Triangle(数学+打表)

题目链接
Problem Description
A triangle is a Heron’s triangle if it satisfies that the side lengths of it are consecutive integers t−1, t, t+ 1 and thatits area is an integer. Now, for given n you need to find a Heron’s triangle associated with the smallest t bigger
than or equal to n.

Input
The input contains multiple test cases. The first line of a multiple input is an integer T (1 ≤ T ≤ 30000) followedby T lines. Each line contains an integer N (1 ≤ N ≤ 10^30).

Output
For each test case, output the smallest t in a line. If the Heron’s triangle required does not exist, output -1.

Sample Input
4
1
2
3
4

Sample Output
4
4
4
4

Source
2017ACM/ICPC亚洲区沈阳站-重现赛(感谢东北大学)
思路:规律题,打表一下就出来了,答案就是a【i】=a【i-1】*4—a【i-2】,由于数很大,果断上java。
由于java大数不是很熟悉,所以码风有点丑。

import java.math.BigInteger;
import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        // TODO Auto-generated method stub
        BigInteger s=BigInteger.valueOf(4);
        Scanner cin=new Scanner(System.in);
        int T=cin.nextInt();
        for(int k=0;k<T;++k)
        {
            BigInteger si=BigInteger.valueOf(4);
            BigInteger two=BigInteger.valueOf(14);
            BigInteger t=cin.nextBigInteger();
            if(t.compareTo(si)<=0) {
                System.out.println(si);
                continue;
            }
            if(t.compareTo(two)<=0) {
                System.out.println(two);
                continue;
            }
            while(true)
            {
                BigInteger temp=two;
                two=two.multiply(s).subtract(si);
                si=temp;
                if(t.compareTo(two)<=0) {
                    System.out.println(two);
                    break;
                }
            }
        }
    }

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值