hdu5698 瞬间移动(组合数学+规律)

题目链接
在这里插入图片描述
Sample Input
4 5

Sample Output
10

Source
2016"百度之星" - 初赛(Astar Round2B)

#include<bits/stdc++.h> 
using namespace std;
const int maxn =2e5+500;
const int mod=1e9+7; 
typedef long long ll;
ll f[maxn],inv[maxn];
ll quick(ll a,ll b){ 
    ll ans=1;  
    a=a%mod;
    while(b!=0){
        if(b&1) ans=(ans*a)%mod;
        b>>=1;
        a=(a*a)%mod;
    }
    return ans;
}
ll slove(int n,int m)
{
    if(m>n) return 0;
    return f[n]*inv[m]%mod*inv[n-m]%mod;
}
int main()
{
    int n,m;
    f[0]=inv[0]=1;
    for(int i=1;i<maxn;++i)
    f[i]=f[i-1]*i%mod,inv[i]=quick(f[i],mod-2)%mod;
    while(scanf("%d %d",&n,&m)!=EOF){
    printf("%lld\n",slove(n+m-4,m-2));
}
 } 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值