【HDU - 6182】【A Math Problem 】

 

Problem Description

You are given a positive integer n, please count how many positive integers k satisfy kk≤n .

 

 

Input

There are no more than 50 test cases.

Each case only contains a positivse integer n in a line.

1≤n≤1018

 

 

Output

For each test case, output an integer indicates the number of positive integers k satisfy kk≤n in a line.

 

 

Sample Input

 

1 4

 

 

Sample Output

 

1 2

 

 

Source

2017ACM/ICPC广西邀请赛-重现赛(感谢广西大学)

解题思路:思考后会发现15^15就已经会爆long long 了,所以直接暴力求解1-15中符合条件的就欧克

ac代码:

#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring> 
using namespace std;
typedef long long ll;
ll n;
int k;
ll ksm(ll a,ll  b)
{
	ll res=1;
	while(b)
	{
		if(b&1) 
			res=res*a;
		a=a*a;
		b>>=1;
	}
	return  res;
}
int main()
{
	while(scanf("%lld",&n)!=EOF)
	{
		int ans=0;
		for(ll i=1;i<=15;i++)
		{
			if(ksm(i,i)>n)
				break; 
			ans++; 
		}
		printf("%d\n",ans);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值