【HDU - 5775】【Bubble Sort】

题目:

 

Problem Description

P is a permutation of the integers from 1 to N(index starting from 1).
Here is the code of Bubble Sort in C++.
for(int i=1;i<=N;++i)
    for(int j=N,t;j>i;—j)
        if(P[j-1] > P[j])
            t=P[j],P[j]=P[j-1],P[j-1]=t;

After the sort, the array is in increasing order. ?? wants to know the absolute values of difference of rightmost place and leftmost place for every number it reached.

Input

The first line of the input gives the number of test cases T; T test cases follow.
Each consists of one line with one integer N, followed by another line with a permutation of the integers from 1 to N, inclusive.
limits
T <= 20
1 <= N <= 100000
N is larger than 10000 in only one case.

iutput

For each test case output “Case #x: y1 y2 … yN” (without quotes), where x is the test case number (starting from 1), and yi is the difference of rightmost place and leftmost place of number i.

 

 

Sample Input

2 3 3 1 2 3 1 2 3

Sample Output

Case #1: 1 1 2 Case #2: 0 0 0

Hint

In first case, (3, 1, 2) -> (3, 1, 2) -> (1, 3, 2) -> (1, 2, 3) the leftmost place and rightmost place of 1 is 1 and 2, 2 is 2 and 3, 3 is 1 and 3 In second case, the array has already in increasing order. So the answer of every number is 0.

 

 

Author

FZU

 

 

Source

2016 Multi-University Training Contest 4

 

 

 解题思路:树状数组求解,找每位数的右侧又多少比它小的,就是这个数可以到达的最右的位置。

ac代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#define maxn 1000000
using namespace std;
int n;
struct node{
	int num;
	int pos;
}nn[maxn];
bool cmp(node a,node b)
{
	return a.num<b.num;
}
int l[maxn],r[maxn];
int c[maxn],pre[maxn];
int lowbit(int x)
{
	return x&-x;
}
void updata(int x,int val)
{
	while(x<=n)
	{
		c[x]+=val;
		x+=lowbit(x);
	}
} 
int query(int x)
{
	int ans=0;
	while(x>0)
	{
		ans+=c[x];
		x-=lowbit(x);
	}
	return ans;
}

int main()
{
	int t;
	cin>>t;
	for(int kase=1;kase<=t;kase++)
	{
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&nn[i].num);	
			pre[nn[i].num]=i;
			nn[i].pos=i;
			l[nn[i].num]=r[nn[i].num]=i;
		}
		sort(nn+1,nn+n+1,cmp);
		memset(c,0,sizeof(c));
		for(int i=1;i<=n;i++)
		{
			int tmp=i-1-query(nn[i].pos);
			r[i]=max(pre[i]+tmp,r[i]);
			l[i]=min(l[i],i);
			updata(nn[i].pos,1);
		}
		printf("Case #%d: ",kase);
		for(int i=1;i<n;i++)
			printf("%d ",abs(r[i]-l[i]));
		printf("%d\n",abs(r[n]-l[n]));	
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值