Bubble Sort HDU - 5775 (树状数组)

P is a permutation of the integers from 1 to N(index starting from 1).
Here is the code of Bubble Sort in C++.
for(int i=1;i<=N;++i)
    for(int j=N,t;j>i;—j)
        if(P[j-1] > P[j])
            t=P[j],P[j]=P[j-1],P[j-1]=t;

After the sort, the array is in increasing order. ?? wants to know the absolute values of difference of rightmost place and leftmost place for every number it reached.

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each consists of one line with one integer N, followed by another line with a permutation of the integers from 1 to N, inclusive.

limits
T <= 20
1 <= N <= 100000
N is larger than 10000 in only one case.
Output
For each test case output “Case #x: y1 y2 … yN” (without quotes), where x is the test case number (starting from 1), and yi is the difference of rightmost place and leftmost place of number i.
Sample Input
2
3
3 1 2
3
1 2 3
Sample Output
Case #1: 1 1 2
Case #2: 0 0 0


        
  
Hint
In first case, (3, 1, 2) -> (3, 1, 2) -> (1, 3, 2) -> (1, 2, 3)
the leftmost place and rightmost place of 1 is 1 and 2, 2 is 2 and 3, 3 is 1 and 3
In second case, the array has already in increasing order. So the answer of every number is 0.

        
题意:对于1到n的一种序列,使用题干的冒泡排序法排序,问对于每个数排序过程中到达的最右端与最左端相差多少。

题目分析:不难发现,对于一个数i,其运动轨迹是先向右移再向左移,原数组i右面有几个比他小的就右移多少格,最左端由i原来的位置和最后的位置最小值决定。

所以最左端O(1)统计,最右端用树状数组优化,时间复杂度O(nlogn)。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int N = 100005;
int arr[N],num[N],pos[N];
int n;
int lowbit(int x){
	return x&(-x);
}
void updata(int x,int data){
	while(x<=n){
		num[x]+=data;
		x+=lowbit(x);
	}
}
int sum(int x){
	int ans=0;
	while(x>0){
		ans+=num[x];
		x-=lowbit(x);
	}
	return ans;
}
int main(){
	int T;
	scanf("%d",&T);
	int cas=0;
	while(T--){
		scanf("%d",&n);
		memset(num,0,sizeof(num));
		for(int i=1;i<=n;i++){
			scanf("%d",&arr[i]);
			pos[arr[i]]=i;
		}
		int r[N]={0};
		for(int i=n;i>=1;i--){
			r[arr[i]]=sum(arr[i]);
			updata(arr[i],1);
		}
		printf("Case #%d:",++cas);
		for(int i=1;i<=n;i++){
			printf(" %d",pos[i]+r[i]-min(pos[i],i));
		}
		printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值