【HDU - 2639】【Bone Collector II】

题目:

The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link: 

Here is the link: http://acm.hdu.edu.cn/showproblem.php?pid=2602 

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum. 

If the total number of different values is less than K,just ouput 0.

Input

The first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone. 

Output

One integer per line representing the K-th maximum of the total value (this number will be less than 2 31). 

Sample Input

3
5 10 2
1 2 3 4 5
5 4 3 2 1
5 10 12
1 2 3 4 5
5 4 3 2 1
5 10 16
1 2 3 4 5
5 4 3 2 1

Sample Output

12
2
0

题意:求解在给定空间下 第k大的价值。

解题思路:可以在01背包的基础上,再开两个数组,存放放与不放的价值,之后,在给定的空间下,将两个数组合并起来,找到最大值。最后直接输出dp[v][k]即可。

ac代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 1005
using namespace std;

int main()
{
	int t;
	int dp[maxn][33],vol[maxn],val[maxn];
	int A[33],B[33];
	cin>>t;
	while(t--)
	{
		int n,k,v;
		cin>>n>>v>>k;
		for(int i=0;i<n;i++)
			cin>>val[i];
		for(int i=0;i<n;i++)
			cin>>vol[i];
		memset(dp,0,sizeof(dp));
		int a,b,c;
		for(int i=0;i<n;i++)
			for(int j=v;j>=vol[i];j--)
			{
				int kk;
				for(kk=1;kk<=k;kk++)
				{
					A[kk]=dp[j-vol[i]][kk]+val[i];
					B[kk]=dp[j][kk];
				}
				A[kk]=-1;
				B[kk]=-1;
				a=b=c=1;
				while(c<=k&&(A[a]!=-1||B[b]!=-1))
				{
					if(A[a]>B[b])
					{
						dp[j][c]=A[a++];
					}
					else
						dp[j][c]=B[b++];
					if(dp[j][c]!=dp[j][c-1])
						c++;
				}
			}
		printf("%d\n",dp[v][k]);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值