题目:
Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the absolute difference between the two scores.
Given the winning numbers for each type of bet, can you deduce the final scores?
Input
The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores.
Output
For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing "impossible". Recall that football scores are always non-negative integers.
Sample Input
2 40 20 20 40
Sample Output
30 10 impossible
解题报告:这道题目就是水题,因为你会找到规律,就是前边的数字不能小于后者,就可以找到了,再根据和差关系就可以找到二者对应的式子,但是有个坑点就是要判断他们是不是整数,因为不是整数的话,会有误差,根本不是咱们想要的结果。
ac代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
int main()
{
int t;
ll a,b,m,n;
cin>>t;
while(t--)
{
cin>>m>>n;
if(m<n||(m+n)%2||(m-n)%2)
{
printf("impossible\n");
continue;
}
printf("%lld %lld\n",(m+n)/2,(m-n)/2);
}
}