【Beat the Spread! 】【POJ - 2301】

题目:

Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the absolute difference between the two scores. 
Given the winning numbers for each type of bet, can you deduce the final scores? 

Input

The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores.

Output

For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing "impossible". Recall that football scores are always non-negative integers.

Sample Input

2
40 20
20 40

Sample Output

30 10
impossible

解题报告:这道题目就是水题,因为你会找到规律,就是前边的数字不能小于后者,就可以找到了,再根据和差关系就可以找到二者对应的式子,但是有个坑点就是要判断他们是不是整数,因为不是整数的话,会有误差,根本不是咱们想要的结果。

ac代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;

int main()
{
	int t;
	ll a,b,m,n;
	cin>>t;
	while(t--)
	{
		cin>>m>>n;
		if(m<n||(m+n)%2||(m-n)%2)
		{
			printf("impossible\n");
			continue;
		}
		printf("%lld %lld\n",(m+n)/2,(m-n)/2);
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值