【POJ - 2301】Beat the Spread! (水题)

Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the absolute difference between the two scores. 
Given the winning numbers for each type of bet, can you deduce the final scores? 

Input

The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores.

Output

For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing "impossible". Recall that football scores are always non-negative integers.

Sample Input

2
40 20
20 40

Sample Output

30 10
impossible

题意:

你已经知道两个数的和与差,看看这两个数存不存在,存在输出这两个数,大的在前。

解题报告:

注意细节,不存在的情况有和比差小和和与差一个是奇数另一个是偶数,这两种情况

ac代码:

#include<stdio.h>
#include<string.h>
#include<queue>
#include<set>
#include<iostream>
#include<map>
#include<stack>
#include<cmath>
#include<algorithm>
#define ll long long
#define mod 1000000007
#define eps 1e-8
using namespace std;
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int add,sub;
		scanf("%d%d",&add,&sub);
		if(add<sub)
			printf("impossible\n");
		else
		{
			int ma=(add+sub)/2,mi=(add-sub)/2;
			if(ma+mi==add&&ma-mi==sub)
			{
				printf("%d %d\n",ma,mi);
			}
			else
			printf("impossible\n");
		}
	}	
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值