【Jolly Jumpers】【UVA - 10038】(水题)

题目:

A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between successive elements take on all the values 1 through n − 1. For instance,

1 4 2 3

is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether or not each of a number of sequences is a jolly jumper.

Input

Each line of input contains an integer n ≤ 3000 followed by n integers representing the sequence.

Output

For each line of input, generate a line of output saying ‘Jolly’ or ‘Not jolly’.

Sample Input

4 1 4 2 3

5 1 4 2 -1 6

Sample Output

Jolly

Not jolly

解题报告:就是给定n,问彼此两个数字之间的差值是不是可以充满从1到n-1,如果可以的话,输出Jolly,否则输出Not jolly

ac代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
typedef long long ll;

const int maxn =50010;

int num[maxn];
int v[maxn];
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		memset(v,0,sizeof(v));
		for(int i=0;i<n;i++)
			scanf("%d",&num[i]);	
		for(int i=0;i<n-1;i++)
		{
			v[i]=abs(num[i]-num[i+1]);
		}
		sort(v,v+n-1);
		int flag=1;
		for(int i=0;i<n-1;i++)
		{
			if(v[i]!=i+1)
			{
				flag=0;
				break;	
			}
			
		}
		if(flag)
			printf("Jolly\n");
		else
			printf("Not jolly\n");//最大的坑点,j居然不是大写
	}	
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值