linux下 opencv 和 ffmpeg安装

1、要先安装ffpmeg

下载地址 http://www.ffmpeg.org/download.html.

这里选择版本3.4.8
选择版本3.4.8

直接下载包上传或者linux直接下载

wget http://www.ffmpeg.org/releases/ffmpeg-3.4.8.tar.gz

解压当前包

tar -zxvf ffmpeg-3.4.8.tar.gz
cd ffmpeg-3.4.8/

安装ffmpeg过程中,执行./configure时,报yasm/nasm not found or too old. Use --disable-yasm for a crippledbuild错误,分析、解决如下:

分析:yasm是汇编编译器,ffmpeg为了提高效率使用了汇编指令,如MMX和SSE等。所以系统中未安装yasm时,就会报上面错误。

解决:安装yasm编译器或者直接–disable-yasm。安装方法如下:

在http://www.tortall.net/projects/yasm/releases下面找到适合自己平台的yasm版本。然后进行安装。举例如下:

1)下载:

wget http://www.tortall.net/projects/yasm/releases/yasm-1.3.0.tar.gz

2)解压并进入解压目录:

tar -zxvf yasm-1.3.0.tar.gz
cd yasm-1.3.0

3)配置:

./configure

4)编译和安装:

make
make install

安装yasm后返回 ffmpeg文件夹下执行编译安装

1) 配置

./configure --enable-shared --prefix=/usr/local/ffmpeg

2) 编译和安装

make
make install

完成之后执行 cd /usr/local/ffmpeg/ 进入安装目录,会有bin,include,lib,share这4个目录。
bin是ffmpeg主程序二进制目录,include是C/C++头文件目录,lib是编译好的库文件目录,share是文档目录。
进入bin目录。
1)查看当前版本的详细信息

./ffmpeg -version

默认情况下一般会报libavdevice.so.57: cannot open shared object file: No such file or directory,原因是lib目录未加载到链接到系统库中,系统ld目录列表在/etc/ld.so.conf中,打开文件会发现,里面引用了/etc/ld.so.conf.d/下面所有的.conf文件,比如mariadb-x86_64.conf.
2)我们只需要创建一个文件并写入lib路径即可

cd /etc/ld.so.conf.d 
touch ffmpeg.conf 

然后执行命令:

vi /etc/ld.so.conf.d/ffmpeg.conf 

然后添加一行内容:

/usr/local/ffmpeg/lib 

之后保存并退出
3)然后执行

ldconfig 

使配置生效,现在再次执行 ./ffmpeg -version 显示就正常了

还有要配置下环境变量,不然待会安装opencv的时候找不到ffmpeg依赖

vi /etc/profile 

添加

export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/local/ffmpeg/lib/pkgconfig

重启让环境变量生效

source /etc/profile

2、安装opencv

下载地址https://opencv.org/releases/.
这里选择版本4.5.3
在这里插入图片描述

1)解压并进入文件夹

unzip opencv-4.5.3.zip
cd opencv-4.5.3

2)新建build文件夹

mkdir build
cd build

3)编译和安装 (注意cmake最后需要写两个点)

cmake -DCMAKE_BUILD_TYPE=RELEASE -DCMAKE_INSTALL_PREFIX=/usr/local -D WITH_FFMPEG=ON ..
sudo make -j8
sudo make install

注意在cmake结束后,在输出的靠近最后的地方,看到FFMPEG这里都是YES,就可以进行后面的make了。

FFMPEG:                      YES
      avcodec:                   YES (ver 56.60.100)
      avformat:                  YES (ver 56.40.101)
      avutil:                    YES (ver 54.31.100)
      swscale:                   YES (ver 3.1.101)
      avresample:                YES (ver 2.1.0)

注意:以上版本是可以对应的,不要装最新版的ffmpeg,否择安装opencv会报某些方法被删除等错误。!!!!!

如果有装其他版本想要重新安装

1)卸载ffmpeg

cd ffmpeg-xx/
make uninstall  ##删除由make install命令安装的文件
make clean  ##只删除make时产生的临时文件
make distclean  ##同时删除configure和make产生的临时文件

2)删除opencv
跟上述类似
不过还要删掉已安装的opencv的include和lib目录,再删除opencv安装目录

rm -rf /usr/local/include/opencv4 /usr/local/share/opencv4 
  • 10
    点赞
  • 36
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值