PTA乙级-1051 复数乘法-C语言版

简单题15分

复数可以写成 (A+Bi) 的常规形式,其中 A 是实部,B 是虚部,i 是虚数单位,满足 i​2​​=−1;也可以写成极坐标下的指数形式 (R×e​(Pi)​​),其中 R 是复数模,P 是辐角,i 是虚数单位,其等价于三角形式 R(cos§+isin§)。
现给定两个复数的 R 和 P,要求输出两数乘积的常规形式。
输入格式:
输入在一行中依次给出两个复数的 R​1​​, P​1​​, R​2​​, P​2​​,数字间以空格分隔。
输出格式:
在一行中按照 A+Bi 的格式输出两数乘积的常规形式,实部和虚部均保留 2 位小数。注意:如果 B 是负数,则应该写成 A-|B|i 的形式。
输入样例:
2.3 3.5 5.2 0.4
输出样例:
-8.68-8.23i

思路:一直没看懂题目,还要懂得复数的相关知识,然后就比较简单,最后注意一下格式。

#include<stdio.h>
#include<math.h>
int main(){
	double R1,R2,P1,P2;
	double a,b;
	scanf("%lf %lf %lf %lf",&R1,&P1,&R2,&P2);
	a = R1*R2*cos(P1+P2);
	b = R1*R2*sin(P1+P2);
	if (fabs(a)<0.01){
		a = 0;
	}
	if (fabs(b)<0.01){
		b = 0;
	}
	printf("%.2lf%+.2lfi",a,b);//+号是格式需要 
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
以下是一元多项式的加法 C 语言代码: ```c #include <stdio.h> #include <stdlib.h> typedef struct node { int coef; // 系数 int exp; // 指数 struct node *next; } Node; Node *createNode(int coef, int exp) { Node *newNode = (Node *)malloc(sizeof(Node)); newNode->coef = coef; newNode->exp = exp; newNode->next = NULL; return newNode; } Node *addPoly(Node *poly1, Node *poly2) { Node *head = createNode(0, 0); Node *p = head; while (poly1 && poly2) { if (poly1->exp > poly2->exp) { p->next = createNode(poly1->coef, poly1->exp); poly1 = poly1->next; } else if (poly1->exp < poly2->exp) { p->next = createNode(poly2->coef, poly2->exp); poly2 = poly2->next; } else { int sum = poly1->coef + poly2->coef; if (sum != 0) { p->next = createNode(sum, poly1->exp); } poly1 = poly1->next; poly2 = poly2->next; } p = p->next; } p->next = poly1 ? poly1 : poly2; return head->next; } void printPoly(Node *poly) { while (poly) { printf("%dx^%d", poly->coef, poly->exp); if (poly->next && poly->next->coef > 0) { printf("+"); } poly = poly->next; } printf("\n"); } int main() { int n, coef, exp; Node *poly1 = createNode(0, 0); Node *poly2 = createNode(0, 0); scanf("%d", &n); for (int i = 0; i < n; i++) { scanf("%d%d", &coef, &exp); Node *node = createNode(coef, exp); node->next = poly1->next; poly1->next = node; } scanf("%d", &n); for (int i = 0; i < n; i++) { scanf("%d%d", &coef, &exp); Node *node = createNode(coef, exp); node->next = poly2->next; poly2->next = node; } Node *sum = addPoly(poly1->next, poly2->next); printPoly(sum); return 0; } ``` 在这个代码中,我们首先定义了一个结构体 `Node` 来存储一元多项式中的每一项。其中,`coef` 表示系数,`exp` 表示指数,`next` 表示指向下一项的指针。 然后,我们通过 `createNode` 函数来创建一个新的节点,并将 `coef` 和 `exp` 初始化为指定的值。 接下来,我们定义了一个 `addPoly` 函数来实现多项式的加法。该函数输入两个多项式的头节点指针 `poly1` 和 `poly2`,并返回一个新的多项式的头节点指针。 在 `addPoly` 函数中,我们先创建一个新的头节点 `head`,然后使用指针 `p` 指向 `head`,依次遍历 `poly1` 和 `poly2` 中的每一项,将它们相加并存储在一个新的节点中,将该节点插入到新多项式的尾部。最后,将剩余的多项式直接连接到新多项式的尾部。 最后,我们定义了一个 `printPoly` 函数来输出一元多项式,然后在 `main` 函数中读入两个多项式,并调用 `addPoly` 函数来求和,最后输出结果。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

sky丶Mamba

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值