PTA乙级-1081 检查密码-C语言版

简单题15分

本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字。
输入格式:
输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。
输出格式:
对每个用户的密码,在一行中输出系统反馈信息,分以下5种:
如果密码合法,输出Your password is wan mei.;
如果密码太短,不论合法与否,都输出Your password is tai duan le.;
如果密码长度合法,但存在不合法字符,则输出Your password is tai luan le.;
如果密码长度合法,但只有字母没有数字,则输出Your password needs shu zi.;
如果密码长度合法,但只有数字没有字母,则输出Your password needs zi mu.。
输入样例:
5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6
输出样例:
Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.

思路:看清题目,理清关系就好了。

#include<stdio.h>
int main(){
	int i,j,N;
	int digit,alpha,error;
	char str;
	scanf("%d",&N);
	getchar();
	for (i=0;i<N;i++){
		digit = 0;
		alpha = 0;
		error = 0;
		for (j=0;(str=getchar())!='\n';j++){
			if (str<='9'&&str>='0'){
				digit++;
			}else if(str>='a'&&str<='z'||str>='A'&&str<='Z'){
				alpha++;
			}else if(str!='.'){
				error++;
			}
		}
		if (j<6){
			printf("Your password is tai duan le.\n");
		}else if (error){
			printf("Your password is tai luan le.\n");
		}else if (!digit&&alpha){
			printf("Your password needs shu zi.\n");
		}else if (!alpha&&digit){
			printf("Your password needs zi mu.\n");
		}else {
			printf("Your password is wan mei.\n");
		}
	}
	return 0;
} 
  • 5
    点赞
  • 9
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
以下是一元多项式的加法 C 语言代码: ```c #include <stdio.h> #include <stdlib.h> typedef struct node { int coef; // 系数 int exp; // 指数 struct node *next; } Node; Node *createNode(int coef, int exp) { Node *newNode = (Node *)malloc(sizeof(Node)); newNode->coef = coef; newNode->exp = exp; newNode->next = NULL; return newNode; } Node *addPoly(Node *poly1, Node *poly2) { Node *head = createNode(0, 0); Node *p = head; while (poly1 && poly2) { if (poly1->exp > poly2->exp) { p->next = createNode(poly1->coef, poly1->exp); poly1 = poly1->next; } else if (poly1->exp < poly2->exp) { p->next = createNode(poly2->coef, poly2->exp); poly2 = poly2->next; } else { int sum = poly1->coef + poly2->coef; if (sum != 0) { p->next = createNode(sum, poly1->exp); } poly1 = poly1->next; poly2 = poly2->next; } p = p->next; } p->next = poly1 ? poly1 : poly2; return head->next; } void printPoly(Node *poly) { while (poly) { printf("%dx^%d", poly->coef, poly->exp); if (poly->next && poly->next->coef > 0) { printf("+"); } poly = poly->next; } printf("\n"); } int main() { int n, coef, exp; Node *poly1 = createNode(0, 0); Node *poly2 = createNode(0, 0); scanf("%d", &n); for (int i = 0; i < n; i++) { scanf("%d%d", &coef, &exp); Node *node = createNode(coef, exp); node->next = poly1->next; poly1->next = node; } scanf("%d", &n); for (int i = 0; i < n; i++) { scanf("%d%d", &coef, &exp); Node *node = createNode(coef, exp); node->next = poly2->next; poly2->next = node; } Node *sum = addPoly(poly1->next, poly2->next); printPoly(sum); return 0; } ``` 在这个代码中,我们首先定义了一个结构体 `Node` 来存储一元多项式中的每一项。其中,`coef` 表示系数,`exp` 表示指数,`next` 表示指向下一项的指针。 然后,我们通过 `createNode` 函数来创建一个新的节点,并将 `coef` 和 `exp` 初始化为指定的值。 接下来,我们定义了一个 `addPoly` 函数来实现多项式的加法。该函数输入两个多项式的头节点指针 `poly1` 和 `poly2`,并返回一个新的多项式的头节点指针。 在 `addPoly` 函数中,我们先创建一个新的头节点 `head`,然后使用指针 `p` 指向 `head`,依次遍历 `poly1` 和 `poly2` 中的每一项,将它们相加并存储在一个新的节点中,将该节点插入到新多项式的尾部。最后,将剩余的多项式直接连接到新多项式的尾部。 最后,我们定义了一个 `printPoly` 函数来输出一元多项式,然后在 `main` 函数中读入两个多项式,并调用 `addPoly` 函数来求和,最后输出结果。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

sky丶Mamba

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值