POJ-3233-Matrix Power Series

题目传送门
Description

Given a n × n matrix A and a positive integer k, find the sum S = A + A2 + A3 + … + Ak.

Input

The input contains exactly one test case. The first line of input contains three positive integers n (n ≤ 30), k (k ≤ 109) and m (m < 104). Then follow n lines each containing n nonnegative integers below 32,768, giving A’s elements in row-major order.

Output

Output the elements of S modulo m in the same way as A is given.

Sample Input

2 2 4
0 1
1 1

Sample Output

1 2
2 3

在这里插入图片描述

#include<cstdio>
#include<cstring>
#define m(a,b) memset(a,b,sizeof a)
using namespace std;
typedef long long ll;
const int N=100;
struct mat{ll a[N][N];};
ll n,mod,p;
mat c;
mat mat_mul(mat x,mat y)
{
    mat res;
    m(res.a,0);
    for(int i=1;i<=2*n;i++)
        for(int j=1;j<=2*n;j++)
            for(int k=1;k<=2*n;k++)
                res.a[i][j]=(res.a[i][j]+(x.a[i][k]*y.a[k][j])%mod)%mod;
    return res;
}
void mat_pow(int p)
{
    mat res,tmp=c;
    m(res.a,0);
    for(int i=1;i<=2*n;i++)
        res.a[i][i]=1;
    while(p)
    {
        if(p&1)
            res=mat_mul(res,c);
        c=mat_mul(c,c);
        p>>=1;
    }
    mat ans;
    m(ans.a,0);
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
            for(int k=1;k<=2*n;k++)
                ans.a[i][j]=(ans.a[i][j]+(res.a[i][k]*tmp.a[k][j+n])%mod)%mod;
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
        {
            if(j!=n)
                printf("%d ",ans.a[i][j]);
            else
                printf("%d\n",ans.a[i][j]);
        }
}
int main()
{
    while(~scanf("%lld%lld%lld",&n,&p,&mod))
    {
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
            {
                scanf("%lld",&c.a[i][j]);
                c.a[i][j]%=mod;
            }    
        for(int i=1;i<=n;i++)
            for(int j=n+1;j<=2*n;j++)
                c.a[i][j]=c.a[i][j-n];
        for(int i=n+1;i<=2*n;i++)
            c.a[i][i]=1;
        for(int i=n+1;i<=2*n;i++)
            for(int j=1;j<=n;j++)
                c.a[i][j]=0;
        mat_pow(p-1);
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值