PAT 1007 Maximum Subsequence Sum (25分)

题目:
Given a sequence of K integers { N​1​​, N​2​​, …, N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, …, N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

解题思路:
本题是一个典型的求最大连续子序列问题,只不过这里还需要输出该最大子序列的第一个数字和最后一个数字,因此可以使用三个数组dp[]、first[]、last[]分别用于保存最大子序列之和以及对应的第一个数字和最后一个数字。
比如上面的一个例子{ -2, 11, -4, 13, -5, -2 },过程如下:
在这里插入图片描述
在这里插入图片描述
最后遍历一遍寻找最大的dp[i]即可。
这里用的是动态规划的方法,时间复杂度只需要O(n),而如果用枚举法的话时间复杂度就达到了平方级。

代码如下:

#include<stdio.h>
#include<iostream>
#define MAX 10001
using namespace std;
int K;
int N[MAX],dp[MAX],first[MAX],last[MAX];//first,last分别为最大子序列所对应的的第一个和最后一个数字

int main() {
	cin >> K;
	for (int i = 0; i < K; i++) {
		cin >> N[i];
	}
	dp[0] = first[0] = last[0] = N[0];
	for (int i = 1; i < K; i++) {
		if (N[i] > dp[i - 1] + N[i]) {
			dp[i] = N[i];
			first[i] = N[i];
			last[i] = N[i];
		}
		else {
			dp[i] = dp[i - 1] + N[i];
			first[i] = first[i - 1];
			last[i] = N[i];
		}		
			
	}
	int maxSum = -1;
	int L;
	for (int i = 0; i < K; i++)
		if (dp[i] > maxSum) {
			maxSum = dp[i];
			L = i;
		}

	if (maxSum == -1)//考虑全是负数的情况
		cout << "0" << " " << N[0] << " " << N[K - 1];
	else
		cout << maxSum << " " << first[L] << " " << last[L];
	
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值