图论-图的遍历 图中点的层次 bfs

19 篇文章 0 订阅

https://www.acwing.com/problem/content/849/
给定一个 n 个点 m 条边的有向图,图中可能存在重边和自环。

所有边的长度都是 1,点的编号为 1∼n。

请你求出 1 号点到 n 号点的最短距离,如果从 1 号点无法走到 n 号点,输出 −1。

输入格式
第一行包含两个整数 n 和 m。

接下来 m 行,每行包含两个整数 a 和 b,表示存在一条从 a 走到 b 的长度为 1 的边。

输出格式
输出一个整数,表示 1 号点到 n 号点的最短距离。

数据范围
1≤n,m≤105
输入样例:
4 5
1 2
2 3
3 4
1 3
1 4
输出样例:
1

import java.util.*;

public class Main
{
	static int n,m,N=100005,q[]=new int [N],d[]=new int [N],hh,tt,idx;
	static int M=N,h[]=new int [N],e[]=new int [M],ne[]=new int [M];
	static void add(int a,int b)
	{
		e[idx]=b;ne[idx]=h[a];h[a]=idx++;
	}
	static int bfs(int u)
	{
		hh=0;tt=0;
		q[hh]=u;
		
		Arrays.setAll(d, t->-1);
		d[u]=0;
		
		while(hh<=tt)
		{
			int t=q[hh++];
			for(int i=h[t];i!=-1;i=ne[i])
			{
				int j=e[i];
				if(d[j]==-1)
				{
					d[j]=d[t]+1;
					q[++tt]=j;
				}
			}
		}
		return d[n];
	}
	
	public static void main(String args[])
	{
		Scanner sc=new Scanner(System.in);
		n=sc.nextInt();m=sc.nextInt();
		Arrays.setAll(h, t->-1);
		for(int i=0;i<m;++i)
		{
			int a, b;
			a=sc.nextInt();
			b=sc.nextInt();
			add(a,b);
		}
		System.out.println(bfs(1));
		
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

wow_awsl_qwq

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值