质因子分解

      首先先来说一个算是结论吧!也可以说是一个数学定义吧:任何一个大于1的自然数N,如果N不为质数,那么N可以分解 成有限个质数的乘积,并且在不计次序的情况下,这种分解 方式是唯一的。

      就是随便给你一个非质数,我们都可以用几个质数的乘积去表示,而且如果不考虑先后顺序的情况下,这几个质数的种类和个数是唯一的。

         今天我们要做的就是给你一个非质数,然后你把它分解成几个质数的乘积,那么我们应该怎么做呢?随便举一个例子吧,假如给定一个数字420,我们怎么做,首先我们从2开始,420%2==0 ,420/2=210,现在我们记录了2这个数字,然后接着,210%2==0,210/2=105,就这样一次循环,最终我们得到420分解为因子是 2 2 3 5 7 。

//复杂度为√n;
map<int,int> ans;
for(int i=0;i*i<=n;i++)
{
    while(n%i==0)
    {
        ++ans[i];
        n/=i;
    }
    if(n!=1) ans[n]=1;//特殊判断,可能最后一个没有算上;
}

上面就是分解质因子的模板;

下面给一道例题,来看一下它的应用吧!

 

While skimming his phone directory in 1982, Albert Wilansky, a mathematician of Lehigh University,noticed that the telephone number of his brother-in-law H. Smith had the following peculiar property: The sum of the digits of that number was equal to the sum of the digits of the prime factors of that number. Got it? Smith's telephone number was 493-7775. This number can be written as the product of its prime factors in the following way: 

4937775= 3*5*5*65837


The sum of all digits of the telephone number is 4+9+3+7+7+7+5= 42,and the sum of the digits of its prime factors is equally 3+5+5+6+5+8+3+7=42. Wilansky was so amazed by his discovery that he named this kind of numbers after his brother-in-law: Smith numbers. 
As this observation is also true for every prime number, Wilansky decided later that a (simple and unsophisticated) prime number is not worth being a Smith number, so he excluded them from the definition. 
Wilansky published an article about Smith numbers in the Two Year College Mathematics Journal and was able to present a whole collection of different Smith numbers: For example, 9985 is a Smith number and so is 6036. However,Wilansky was not able to find a Smith number that was larger than the telephone number of his brother-in-law. It is your task to find Smith numbers that are larger than 4937775!

Input

The input file consists of a sequence of positive integers, one integer per line. Each integer will have at most 8 digits. The input is terminated by a line containing the number 0.

Output

For every number n > 0 in the input, you are to compute the smallest Smith number which is larger than n,and print it on a line by itself. You can assume that such a number exists.

Sample Input

4937774
0

Sample Output

4937775

 

#include<stdio.h>
#include<string.h>
#define ll long long
ll A(ll n)        //计算一个数字的位上的数字的和;
{
    ll sum=0;
    while(n)
    {
        sum+=n%10;
        n=n/10;
    }
    return sum;
}

ll B(ll n)         //计算一个数字的所有质因子的和;
{
    ll sum=0;
    ll m=n;
    for(ll i=2;i*i<=m;i++)
    {
        while(n%i==0)
        {
            sum+=A(i);
            n=n/i;
        }
    }
    if(m==n) return -1;//排除素数的干扰,就是题目要求这个数字不能为素数; 
    if(n!=1) sum+=A(n);//别忘了最后的特殊情况;
    return sum;
}

int main()
{
    ll n,sum1,sum2;
    while(scanf("%lld",&n)&&n)
    {
       
        for(ll i=n+1;;i++)
        {
        	 sum1=A(i);
            sum2=B(i);
            if(sum1==sum2)
            {
                printf("%lld\n",i);
                break;
            }
        }
    }

    return 0;
}

 

 

评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值