hdu -1028

http://acm.hdu.edu.cn/showproblem.php?pid=1028

Problem Description

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"

 

 

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

 

 

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

 

 

Sample Input

 

4 10 20

 

 

Sample Output

 

5 42 627

 这个题的大致意思就是说给你一个数n问它可以有几种其他的非负整数组成,很明显的组合问题,本来是无从下手的,但是现在我们有母函数这个技能了,下面给出AC代码:

#include<stdio.h>
#include<string.h>
using namespace std;
const int maxn=120*120;
int c1[maxn],c2[maxn];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(c2,0,sizeof(c2));
        for(int i=0;i<=n;i++)
            c1[i]=1;
        for(int i=2;i<=n;i++)//乘的是第二个多项式;
        {
            for(int j=0;j<=n;j++)//此时的多项式的每一项;
            {
                for(int k=0;k+j<=n;k+=i)//被乘的多项式的每一项
                    c2[k+j]+=c1[j];
            }
            for(int i=0;i<=n;i++)
                c1[i]=c2[i];
            memset(c2,0,sizeof(c2));
        }
        printf("%d\n",c1[n]);
    }
    return 0;
}

//hdu--1028

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值