Ordering Tasks

UVA - 10305 

题目:

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.

Input

The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1 ≤ n ≤ 100 and m. n is the number of tasks (numbered from 1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. An instance with n = m = 0 will finish the inp

Output

For each instance, print a line with n integers representing the tasks in a possible order of execution.

Sample Input

5 4

1 2

2 3

1 3

1 5

0 0

Sample Output

1 4 2 5 3

 

翻译一下:

约翰有n个任务要做。不幸的是,任务不是独立的,一个任务的执行是独立的只有在其他任务已经执行时才有可能。

输入

输入将包含问题的几个实例。

每个实例以包含的行开始两个整数,1≤n≤100 m . n是任务的数量(编号从1到n)和m任务之间的直接优先关系的数量。

在此之后,将会有m行,有两个整数i和j,表示任务i必须在任务j之前执行。n = m = 0的实例将完成输入。

输出

对于每个实例,以可能的执行顺序打印一行n个整数表示任务。

 

题解:用队列来辅助的一个拓扑排序

代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
using namespace std;
const int MAXN=1e2+10;
int vis[MAXN];
int a[MAXN][MAXN];
int temp[MAXN];
queue<int> que;
int n,m;
void toposort(){
	for(int j=1;j<=n;j++){
		if(vis[j]==0){
			que.push(j);
		}
	}
	int cnt=0;
	while(!que.empty()){
		int t=que.front();
		que.pop();
		temp[++cnt]=t;
		for(int j=1;j<=n;j++){
			if(a[t][j]==1){
				vis[j]--;
				if(vis[j]==0){
					que.push(j);
				}
			}
		}
	}
	for(int i=1;i<=cnt;i++){
		printf("%d",temp[i]);
		if(i!=cnt) printf(" ");
		else printf("\n");
	}
}
int main(){
	int x,y;
	while(~scanf("%d %d",&n,&m)&&(n||m)){  //不写成(m||n)会wa掉
		memset(a,0,sizeof(a));
		memset(vis,0,sizeof(vis));
		memset(temp,0,sizeof(temp));
		for(int i=1;i<=m;i++){
			scanf("%d %d",&x,&y);
			if(a[x][y]==0){
				a[x][y]=1;
				vis[y]++;
			}
		}
		toposort();
	}
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Guava Ordering是一个用于排序的工具类,它为构建复杂的比较器提供了一种流畅的风格。通过使用Guava Ordering,我们可以根据自定义的规则对集合中的元素进行排序。 在Guava Ordering中,有三种静态方法用于创建Ordering排序器:natural()、usingToString()和from(Comparator)。natural()方法使用自然排序规则生成排序器,即从小到大的顺序。usingToString()方法根据元素的toString()方法返回值进行排序。from(Comparator)方法根据给定的Comparator生成排序器。 创建Ordering排序器后,可以使用它对集合或元素进行操作。常见的方法包括sortedCopy(List)、immutableSortedCopy(Iterable)、min(E, E)和max(E, E)等。sortedCopy(List)方法返回一个已排序的List副本,immutableSortedCopy(Iterable)方法返回一个不可变的已排序集合,min(E, E)方法返回两个元素中较小的那个,max(E, E)方法返回两个元素中较大的那个。 下面是一个示例代码,展示了如何使用Guava Ordering对People类的age属性进行排序: List<People> peopleList = new ArrayList<People>() { { add(new People("A", 33)); add(new People("B", 11)); add(new People("C", 18)); } }; Ordering<People> ordering = Ordering.natural().onResultOf(new Function<People, Comparable>() { @Override public Comparable apply(People people) { return people.getAge(); } }); for (People p : ordering.sortedCopy(peopleList)) { System.out.println(MoreObjects.toStringHelper(p) .add("name", p.getName()) .add("age", p.getAge())); } 这段代码中,我们首先创建了一个包含People对象的List。然后使用Ordering.natural().onResultOf()方法创建了一个排序器,该排序器按照People对象的age属性进行排序。最后,我们通过ordering.sortedCopy()方法将集合按照排序规则进行排序,并打印排序后的结果。 通过使用Guava Ordering,我们可以轻松地实现各种排序需求,并且可以方便地链式调用方法来定制和增强现有的比较器。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值