nyoj-58 最小步数(bfs||dfs)

搜素的模板题dfs||bfs都可以。
题目传送门
最小步数
时间限制:3000 ms | 内存限制:65535 KB
描述
这有一个迷宫,有0~8行和0~8列:

1,1,1,1,1,1,1,1,1
1,0,0,1,0,0,1,0,1
1,0,0,1,1,0,0,0,1
1,0,1,0,1,1,0,1,1
1,0,0,0,0,1,0,0,1
1,1,0,1,0,1,0,0,1
1,1,0,1,0,1,0,0,1
1,1,0,1,0,0,0,0,1
1,1,1,1,1,1,1,1,1

0表示道路,1表示墙。
现在输入一个道路的坐标作为起点,在输入一个道路的坐标作为终点,问最少走几步才能从起点到达终点?(注:一步是指从一坐标点走到其上下左右相邻坐标点,如:从(3,1)到(4,1)。)
输入
第一行输入一个整数n(0-100],表示有n组数据;
随后n行,每行有四个整数a,b,c,d(0<=a,b,c,d<=8)分别表示起点的行、列,终点的行、列。
输出
输出最少走几步。
样例输入
2
3 1 5 7
3 1 6 7
样例输出
12
11



dfs

#include<stdio.h>
const int maxn=10000;
int sx,sy,ex,ey;
int map[9][9]={
    1,1,1,1,1,1,1,1,1,
 1,0,0,1,0,0,1,0,1,
 1,0,0,1,1,0,0,0,1,
 1,0,1,0,1,1,0,1,1,
 1,0,0,0,0,1,0,0,1,
 1,1,0,1,0,1,0,0,1,
 1,1,0,1,0,1,0,0,1,
 1,1,0,1,0,0,0,0,1,
 1,1,1,1,1,1,1,1,1
};
int vis[9][9];
int d[4][2]={0,1,0,-1,1,0,-1,0};
int ans;
void dfs(int x,int y,int c)
{
    if(map[x][y])
    return ;
    c++;
    if(x==ex&&y==ey)
    {
        if(c<ans)
        ans=c;
        return ;
    }
    map[x][y]=1;
    dfs(x,y+1,c);
    dfs(x+1,y,c);
    dfs(x-1,y,c);
    dfs(x,y-1,c);
    map[x][y]=0;
}
int main()
{
        int n;
    scanf("%d",&n);
    while(n--)
    {
        int c=0;
        scanf("%d%d%d%d",&sx,&sy,&ex,&ey);
        ans=maxn;
        dfs(sx,sy,c);
        printf("%d\n",ans-1);
    }
return 0;
}

bfs

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int map[9][9]={
1,1,1,1,1,1,1,1,1,
1,0,0,1,0,0,1,0,1,
1,0,0,1,1,0,0,0,1,
1,0,1,0,1,1,0,1,1,
1,0,0,0,0,1,0,0,1,
1,1,0,1,0,1,0,0,1,
1,1,0,1,0,1,0,0,1,
1,1,0,1,0,0,0,0,1,
1,1,1,1,1,1,1,1,1,
};
struct node
{
    int x,y,step;
};
bool vis[9][9];
int x,y,ex,ey;
int dx[4]={0,0,-1,1},dy[4]={1,-1,0,0};
int BFS(){
    node s;
    s.x=x,s.y=y,s.step=0;
    vis[x][y]=true;
    queue<node>q;
    q.push(s);
    while(!q.empty())
    {
        node now=q.front();
        q.pop();
        if(now.x==ex&&now.y==ey)
        {
        return now.step;
        }
        for(int i=0;i<4;i++)
        {
            node end;
            end.x=now.x+dx[i];
            end.y=now.y+dy[i];
            end.step=now.step;
            if(vis[end.x][end.y]==false&&map[end.x][end.y]==0)
            {
                vis[end.x][end.y]=true;
                end.step+=1;
                q.push(end);
            }
        }
    }
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        memset(vis,false,sizeof(vis));
        scanf("%d%d%d%d",&x,&y,&ex,&ey);
        int ans=BFS();
        printf("%d\n",ans);
    }
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值