树状数组之POJ3270Cow Sorting

Cow Sortinghttp://poj.org/problem?id=3270
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7932 Accepted: 3119
Description

Farmer John’s N (1 ≤ N ≤ 10,000) cows are lined up to be milked in the evening. Each cow has a unique “grumpiness” level in the range 1…100,000. Since grumpy cows are more likely to damage FJ’s milking equipment, FJ would like to reorder the cows in line so they are lined up in increasing order of grumpiness. During this process, the places of any two cows (not necessarily adjacent) can be interchanged. Since grumpy cows are harder to move, it takes FJ a total of X+Y units of time to exchange two cows whose grumpiness levels are X and Y.

Please help FJ calculate the minimal time required to reorder the cows.

Input

Line 1: A single integer: N.
Lines 2..N+1: Each line contains a single integer: line i+1 describes the grumpiness of cow i.
Output

Line 1: A single line with the minimal time required to reorder the cows in increasing order of grumpiness.
Sample Input

3
2
3
1
Sample Output

7
题目:有一串数字,要将它排列成升序,每次可以交换两个数,交换一次的代价为两数之和。要求代价最小。

从小到大排列花费的权值==逆序数权值和

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#define ll long long
using namespace std;
const int N=101000;
int c[N],vis[N];
int lowbit(int x)
{
    return x&(-x);
}
void up(int x,int v)
{

    for(int i=x;i<=N-1;i+=lowbit(i)) c[i]+=v;
}
int sum(int x)
{
    int res=0;
    for(int i=x;i>0;i-=lowbit(i)) res+=c[i];
    return res;
}
int main()
{
    int n;
    long long ans=0;
    cin>>n;

        memset(c,0,sizeof(c));

        for(int i=1;i<=n;i++)
        {
            cin>>vis[i];

        }
        for(int i=n;i>0;i--)
        {
             ans+=(ll)sum(vis[i]-1)*vis[i];
            up(vis[i],1);
        }
         memset(c,0,sizeof(c));
         for(int i=1;i<=n;i++)
    {
        ans+=(ll)(sum(N)-sum(vis[i]))*vis[i];
        up(vis[i],1);
    }

            cout<<ans<<endl;

    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值