SDUT1061——Binomial Showdown

Binomial Showdown
Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic Discuss

Problem Description
In how many ways can you choose k elements out of n elements, not taking order into account?
Write a program to compute this number.

Input
The input file will contain one or more test cases.
Each test case consists of one line containing two integers n (n>=1) and k (0<=k<=n).
Input is terminated by two zeroes for n and k.

Output
For each test case, print one line containing the required number. This number will always fit into an integer, i.e. it will be less than 231.
Warning: Don’t underestimate the problem. The result will fit into an integer - but if all intermediate results arising during the computation will also fit into an integer depends on your algorithm. The test cases will go to the limit.

Sample Input
4 2
10 5
49 6
0 0

Sample Output
6
252
13983816

**题意:**给你两个数 n 和 k ,让你计算其排列数C(n , k)

**提示:**不能直接用C(n , m)公式计算,因为数据增长速度很快,测试数据很大,会爆的,所以应根据原有公式就行优化,边算边除,这样就可以了
这里写图片描述


AC代码:


#include <bits/stdc++.h>
using namespace std;
int main()
{
    long long n,m,sum,i;
    while(cin>>n>>m&&n)
    {
        if(n<m) break;
        if(m==0) cout<<"1\n";
        else
        {
            sum=1;
            m=m<(n-m)?m:(n-m);  //尽可能的减小算法时间复杂度
            for(i=1; i<=m; i++)
                sum=(sum*(n-m+i))/i;
            cout<<sum<<endl;
        }
    }
    return 0;
}




余生还请多多指教!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值