poj 2249 Binomial Showdown

Binomial Showdown
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14828 Accepted: 4549

Description

In how many ways can you choose k elements out of n elements, not taking order into account?
Write a program to compute this number.

Input

The input will contain one or more test cases.
Each test case consists of one line containing two integers n (n>=1) and k (0<=k<=n).
Input is terminated by two zeroes for n and k.

Output

For each test case, print one line containing the required number. This number will always fit into an integer, i.e. it will be less than 2 31.
Warning: Don't underestimate the problem. The result will fit into an integer - but if all intermediate results arising during the computation will also fit into an integer depends on your algorithm. The test cases will go to the limit.

Sample Input

4 2
10 5
49 6
0 0

Sample Output

6
252
13983816
#include<iostream>
using namespace std;



__int64 fun(int a , int b , int c)
{
__int64 kk = 1 ;
int wk = a , wk2 = 1 ;
for(wk = c ; wk >= b + 1 ; wk-- )
{
kk *= wk ;
if( kk % a == 0 && a > 0)
kk /= a-- ;
}
while( a && a >= 1 )
{
wk2 *= a-- ;
}
return kk / wk2;
}




int main()
{
int N = 0 , M = 0 ;
while( scanf( "%d%d" , &N , &M) , N + M !=0)
{
int min = 0, max =0 ;
if( N - M > M )
{
min = M ;
max = N - M ;
}
else
{
max = M;
min = N - M ;
}
cout<<fun( min , max , N)<<"\n" ;
}
return 0;
}
 

转载于:https://www.cnblogs.com/w0w0/archive/2011/11/22/2258287.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值