某年某月的天数

C语言实验——某年某月的天数
Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description
输入年和月,判断该月有几天?

Input
输入年和月,格式为年\月。

Output
输出该月的天数。

Sample Input
2009\1

Sample Output
31

Hint
注意判断闰年啊

提示:split()把字符串分割为字符串数组。

AC代码:

import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner mi = new Scanner(System.in);
		while (mi.hasNext()) {
			String Str = mi.nextLine().trim();
			String a[] = Str.split("\\\\");
			int n = Integer.parseInt(a[0]);
			int m = Integer.parseInt(a[1]);
			if (m == 1 || m == 3 || m == 5 || m == 7 || m == 8 || m == 10 || m == 12) {
				System.out.println("31");
			} else if (m == 2) {
				if ((n % 4 == 0 && n % 100 != 0) || n % 400 == 0) {
					System.out.println("29");
				} else {
					System.out.println("28");
				}
			} else {
				System.out.println("30");
			}
		}
		mi.close();
	}
}

——————
余生还请多多指教!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值