数据结构实验之查找一:二叉排序树

Problem Description
对应给定的一个序列可以唯一确定一棵二叉排序树。然而,一棵给定的二叉排序树却可以由多种不同的序列得到。例如分别按照序列{3,1,4}和{3,4,1}插入初始为空的二叉排序树,都得到一样的结果。你的任务书对于输入的各种序列,判断它们是否能生成一样的二叉排序树。

Input
输入包含若干组测试数据。每组数据的第1行给出两个正整数N (n < = 10)和L,分别是输入序列的元素个数和需要比较的序列个数。第2行给出N个以空格分隔的正整数,作为初始插入序列生成一颗二叉排序树。随后L行,每行给出N个元素,属于L个需要检查的序列。
简单起见,我们保证每个插入序列都是1到N的一个排列。当读到N为0时,标志输入结束,这组数据不要处理。

Output
对每一组需要检查的序列,如果其生成的二叉排序树跟初始序列生成的二叉排序树一样,则输出"Yes",否则输出"No"。

Sample Input
4 2
3 1 4 2
3 4 1 2
3 2 4 1
2 1
2 1
1 2
0

Sample Output
Yes
No
No

AC代码:

#include<bits/stdc++.h>
using namespace std;
typedef struct tree
{
    int data;
    struct tree *l,*r;
} Tr;
int k=1;
Tr *Creat(Tr *root,int x)
{
    if(root==NULL)
    {
        root=new Tr();// root=(Tr *)malloc(sizeof(Tr));  || root=new Tr;
        root->data=x;
        root->l=root->r=NULL;
    }
    else
    {
        if(root->data>x) root->l=Creat(root->l,x);
        else root->r=Creat(root->r,x);
    }
    return root;
}
void Judegs(Tr *root1,Tr *root2)
{
    if(root1&&root2)
    {
        if(root1->data!=root2->data)
        {
            k=0;
            return;
        }
        Judegs(root1->l,root2->l);
        Judegs(root1->r,root2->r);
    }
}
int main()
{
    int n,m,a[11],b[11];
    while(cin>>n&&n!=0)
    {
        cin>>m;
        for(int i=1; i<=n; i++)
        {
            cin>>a[i];
        }
        Tr *root1=NULL;
        for(int i=1; i<=n; i++)
        {
            root1=Creat(root1,a[i]);
        }
        while(m--)
        {
            for(int i=1; i<=n; i++)
            {
                cin>>b[i];
            }
            Tr *root2=NULL;
            for(int i=1; i<=n; i++)
            {
                root2=Creat(root2,b[i]);
            }
            Judegs(root1,root2);
            if(k==0) cout<<"No\n";
            else cout<<"Yes\n";
        }
    }
    return 0;
}

————
余生还请多多指教!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值