PAT 甲级 1004(Counting Leaves)

题目要求

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:
2 1
01 1 02

Sample Output:
0 1

翻译

题目很长,大致意思是
输入
N 树的结点数 (0,100)
M 非叶子结点数
接下来M行
ID K ID[1] ID[2] … ID[k]
ID 2位数,表示非叶子结点的编号,k是儿子结点的个数 接下来k个儿子结点的ID, 记根节点为01
输出
每层叶子结点的个数

代码

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
vector<int> v[100];
int book[100];
int maxDepth=-1;
void dfs(int index, int depth)
{
    if(v[index].size()==0)
    {
        book[depth]++;
        maxDepth=max(maxDepth,depth);
        return ;
    }
    for(int i=0;i<v[index].size();i++)
    {
        dfs(v[index].at(i),depth+1);
    }
}
int main()
{
    int N,M;
    int node,K;
    while(cin >>N>>M)
    {
        for(int i=0;i<M;i++)
        {
            cin >>node>>K;
            for(int j=0;j<K;j++)
            {
                int tmp;
                cin>>tmp;
                v[node].push_back(tmp);
            }
        }
        dfs(1,0);
        cout<<book[0];
        for(int i=1;i<=maxDepth;i++)
        {
            cout<<" "<<book[i];
        }
    }
    return 0;
}

思路

很显然这是二叉树遍历问题,这里使用深度优先算法,这里给个简单的例子说明一下,
在这里插入图片描述
以上面二叉树为例,深度优先搜索的顺序

为:ABDECFG。怎么实现这个顺序呢 ?深度优先搜索二叉树是先访问根结点,然后遍历左子树接着是遍历右子树。

	if(v[index].size()==0)
    {
        book[depth]++;
        maxDepth=max(maxDepth,depth);
        return ;
    }
    for(int i=0;i<v[index].size();i++)
    {
        dfs(v[index].at(i),depth+1);
    }

这里使用递归的方法寻找叶子节点,并一层层深入搜索。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值