PAT甲级1004

1004 Counting Leaves (30 point(s))

题目原文

  A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:
  Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]>

  where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.
  The input ends with N being 0. That case must NOT be processed.

Output Specification:
  For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
  The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:
2 1
01 1 02

Sample Output:
0 1

题目大意

  题目首先给出N,M,分别代表总结点数和非叶子结点数,随后给出M行(格式为结点编号,孩子结点数,孩子编号),最后要求输出每一层的叶子结点数。

解题思路

  本题首先遇到的第一个问题,就是如何存储这棵树,要注意这并非一颗二叉树,所以建议用树的静态结构实现。再辅之以层次遍历,同时判断该结点是否有孩子,如果没有就累加该层的叶子结点数。具体实现见如下代码

代码

#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <vector>
#include <queue>//以便层序遍历
using namespace std;

const int maxn = 110;
struct node {
	int layer;
	vector<int> child;
}Node[maxn];//存储层次和孩子结点

int res[maxn] = { 0 };//表示每层有多少个叶子节点
int maxLayer = 0;//树的高度

void layerOrder(int root) {
	queue<int> que;
	Node[root].layer = 1;//根节点位于第一层
	que.push(root);
	while (!que.empty()) {
		int top = que.front();
		que.pop();
		if (Node[top].child.empty()) {//如果该结点没有孩子,则累加该层的叶子节点数
			++res[Node[top].layer];
		}			
		for (int i = 0; i < Node[top].child.size(); ++i) {
			int child = Node[top].child[i];
			Node[child].layer = Node[top].layer + 1;	
			if (maxLayer < Node[child].layer) {//得到树的高度
				maxLayer = Node[child].layer;
			}				
			que.push(child);
		}
	}
}

int main()
{
	int N, M, i, father, child, cnt;
	int ret = scanf("%d %d", &N, &M);
	for (i = 0; i < M; ++i) {
		ret = scanf("%d %d", &father, &cnt);
		for (int k = 0; k < cnt; ++k) {
			ret = scanf("%d", &child);
			Node[father].child.push_back(child);
		}
	}
	layerOrder(1);//根节点为1
	for (int i = 1; i <= maxLayer; ++i) {
		if (i > 1)
			printf(" ");
		printf("%d", res[i]);
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值