Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1k1×p2k2×⋯×pmkm.
Input Specification:
Each input file contains one test case which gives a positive integer N in the range of long int.
Output Specification:
Factor N in the format N =
p1^
k1*
p2^
k2*
…*
pm^
km, where pi's are prime factors of N in increasing order, and the exponent ki is the number of pi -- hence when there is only one pi, ki is 1 and must NOT be printed out.
Sample Input:
97532468
Sample Output:
97532468=2^2*11*17*101*1291
#include <iostream>
#include<cmath>
#include <vector>
using namespace std;
const int maxn= 1 << 16;
bool p[maxn] = {false};
vector<int> prime;
int main() {
int n;
cin >> n;
if(n == 1){ cout << "1=1";return 0;}//测试点3输出要用
int sqr = sqrt(n);
for(int i = 2; i <= sqr; i++){
if(p[i] == false){
prime.push_back(i);
for(int j = 1; j * i <= sqr; j++)
p[i * j] = true;
}
}
int len = prime.size();
cout << n << "=";
for(int i = 0; i < len; i++){
int cnt = 0, temp = n;
while(n % prime[i] == 0){
cnt++;
n /= prime[i];
}
if(temp != n){
cnt > 1 ? cout << prime[i] << "^" << cnt : cout << prime[i];
if(n != 1) cout << "*";
}
}
if(n!=1) cout << n;
return 0;
}