1059. Prime Factors (25)-PAT甲级真题

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1​k1​×p2​k2​×⋯×pm​km​.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1​^k1​*p2​^k2​**pm​^km​, where pi​'s are prime factors of N in increasing order, and the exponent ki​ is the number of pi​ -- hence when there is only one pi​, ki​ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291
#include <iostream>
#include<cmath>
#include <vector>
using namespace std;
const int maxn= 1 << 16;
bool p[maxn] = {false};
vector<int> prime;
int main() {
    int n;
    cin >> n;
    if(n == 1){ cout << "1=1";return 0;}//测试点3输出要用
    int sqr = sqrt(n);
    for(int i = 2; i <= sqr; i++){
        if(p[i] == false){
            prime.push_back(i);
            for(int j = 1; j * i <= sqr; j++) 
                p[i * j] = true;
        }
    }
    int len = prime.size();
    cout << n << "=";
    for(int i = 0; i < len; i++){
        int cnt = 0, temp = n;
        while(n % prime[i] == 0){
            cnt++;
            n /= prime[i];
        }
        if(temp != n){
            cnt > 1 ? cout << prime[i] << "^" << cnt : cout << prime[i];
            if(n != 1) cout << "*";
        }
    }
    if(n!=1) cout << n;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值