计算机网络之三层交换机VLAN间路由

学习目的:

1、掌握三层交换机VLAN路由的配置方法。

2、理解VLAN,掌握VLAN的划分和配置方法。

3、通过三层交换机实现VLAN间相互通信。

相关理论:

  • VLAN(Virtual Local Area Network,虚拟局域网)是一种将同一物理局域网设备从逻辑上划分成一个个不同网段,从而实现虚拟工作组的数据交换技术 。
  •  VLAN把同一物理局域网内的不同用户逻辑地划分成不同的广播域,每一个VLAN都包含一组有着相同需求的计算机工作站,与物理上形成的LAN有着相同的属性。

学习内容:

  • 通过对三层交换机VLAN配置,依旧用上一次的网络拓扑图,继续学习三层交换机VLAN间路由。
  • 利用第三层交换机划分VLAN,实现VLAN的划分的网络之间互相访问,实现VLAN间路由,VLAN网络中的设备访问服务器Server1、Server2。

一、建立如下Packet Tracer拓扑图。配置Server0,Server1服务器的IP地址及网关,启动路由器接口,配置路由器端口IP、子网掩码。

二、配置路由器Router1,配置RIP路由协议。

Router>en
Router#config t
//配置fa 0/0 端口ip、子掩码
Router(config)#interface fa0/0
Router(config-if)#ip address 192.168.3.20 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
//配置fa 0/1 端口ip、子掩码
Router(config)#interface fa0/1
Router(config-if)#ip address 192.168.4.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
//配置eth 1/0 端口ip、子掩码
Router(config)#interface eth1/0
Router(config-if)#ip address 192.168.5.10 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
//配置RIP动态路由
Router(config)#route rip
Router(config-router)#network 192.168.3.0
Router(config-router)#network 192.168.4.0
Router(config-router)#network 192.168.5.0
Router(config-router)#version 2
Router(config-router)#exit

 

 

三、配置路由器Router2,配置RIP路由协议。

Router>en
Router#config t
//配置fa 0/0 端口ip、子掩码
Router(config)#interface fa0/0
Router(config-if)#ip address 192.168.5.20 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
//配置fa 0/1 端口ip、子掩码
Router(config)#interface fa0/1
Router(config-if)#ip address 192.168.6.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
//配置RIP动态路由
Router(config)#route rip
Router(config-router)#network 192.168.5.0
Router(config-router)#network 192.168.6.0
Router(config-router)#version 2
Router(config-router)#exit

四、建立 trunk 用于多个交换机之间运行多个VLAN , 设置为trunk 线路 。

Switch>en
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)# interface f0/1
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Switch(config)# interface f0/2
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Switch(config)#

五、在三层交换机上创建 vlan及vlan 端口,与交换机连接需设立vlan,划分端口到vlan 并设置该网段网关地址,与路由器连接同样要设立vlan 及端口IP。

Switch>en
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#interface f0/1    // 将端口加入vlan 10
Switch(config-if)#switchport access vlan 10
Switch(config-if)#interface vlan 10  //vlan 10
Switch(config-if)#no shutdown
Switch(config-if)#ip address 192.168.1.1 255.255.255.0  // 设置端口地址
Switch(config-if)#no shutdown
Switch(config-if)#exit

Switch(config)#vlan 20
Switch(config-vlan)#exit
Switch(config)#interface f0/2
Switch(config-if)#switchport access vlan 20
Switch(config-if)#interface vlan 20
Switch(config-if)#no shutdown
Switch(config-if)#ip address 192.168.2.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#ip routing          // 开启路由转发功能
Switch(config)#

六、实现了VLAN10与VLAN20划分的网络之间互相访问。

七、配置VLAN30,与路由器连接同样要设立VLAN30及端口IP。

Switch(config)#vlan 30
Switch(config-vlan)#exit
Switch(config)#interface f0/3                  // 将端口加入vlan 30
Switch(config-if)#switchport access vlan 30
Switch(config-if)#interface vlan 30
Switch(config-if)#
Switch(config-if)#no shutdown
Switch(config-if)#ip address 192.168.3.10 255.255.255.0          // 设置端口地址
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#router rip              //配置RIP路由协议
Switch(config-router)#network 192.168.1.0
Switch(config-router)#network 192.168.2.0
Switch(config-router)#network 192.168.3.0
Switch(config-router)#version 2
Switch(config-router)#exit
Switch(config)#

八、VLAN网络中的设备访问服务器Server1、Server2。

 

相关推荐
©️2020 CSDN 皮肤主题: 技术工厂 设计师:CSDN官方博客 返回首页