1059 Prime Factors (25 分)(唯一分解定理,特判1=1,呵呵)

 

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p​1​​​k​1​​​​×p​2​​​k​2​​​​×⋯×p​m​​​k​m​​​​.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p​1​​^k​1​​*p​2​​^k​2​​**p​m​​^k​m​​, where p​i​​'s are prime factors of N in increasing order, and the exponent k​i​​ is the number of p​i​​ -- hence when there is only one p​i​​, k​i​​ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

特判1=1

 

#include<bits/stdc++.h>
#pragma GCC optimize(3)
#define max(a,b) a>b?a:b
using namespace std;
typedef long long ll;
const int N=5e5+5;
int prime[N],cnt=0;
bool p[N];
void is_p(){
	p[0]=p[1]=true;
	for(int i=2;i<N;i++){
		if(!p[i]) prime[cnt++]=i;
		for(int j=0;j<cnt&&(ll)i*prime[j]<N;j++){
			p[i*prime[j]]=true;
			if(i%prime[j]==0) break;
		}
	}
}
struct node{
	int p,k;
}a[N];
int main(){
    is_p();
    int n;
    scanf("%d",&n);
    int x=n;
    printf("%d=",n);
    if(n==1){
    	printf("%d\n",n);
	return 0; 
    } 
    int t=0;
    for(int i=0;i<cnt&&x!=1;i++){
    	if(x%prime[i]==0){
    	   int res=0;
    	   while(x%prime[i]==0){
    		res++;
    		x/=prime[i];
	   }
	   a[++t]={prime[i],res};
	}
    }
    if(x!=1) a[++t]={x,1};
    for(int i=1;i<=t;i++){
	printf("%d",a[i].p);
	if(a[i].k>1) printf("^%d",a[i].k);
	printf("%c","*\n"[i==t]);
    }
    return 0;
}





 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值