Subsequence

Subsequence

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output
2
3
题意:
给定长度为n的数列以及整数S,求出总和不小于S的连续子序列的长度的最小值。如果解不存在,则输出0。

这道题可以用二分法枚举答案,也可以用尺取法做。
尺取法还没学,以后学了再写吧

二分法代码

#include<cstdio>
using namespace std;
const int maxn=100005;
int a[maxn];
int sum[maxn];//前n项和,sum[n]=a[1]+a[2]+...+a[n]
int main() {
	int t,n,s;
	scanf("%d",&t);
	while(t--) {
		scanf("%d%d",&n,&s);
		for(int i=1; i<=n; i++) {
			scanf("%d",&a[i]);
			if(i==1) sum[i]=a[i];
			else sum[i]=sum[i-1]+a[i];
			//预先以O(n)的时间计算好sum,就可以以O(1)的时间计算区间上的总和
			//a[s]+a[s+1]+...+a[t]=sum[t]-sum[s-1]
		}

		if(sum[n]<s) {     //总和小于S,解不存在,输出0
			printf("0\n");
			continue;
		}
		int res=n;
		for(int i=1; i<=n; i++) {    //子序列从i下标开始
			int l=i,r=n,m;
			while(r>=l) {
				m=(l+r)>>1;
				if(sum[m]-sum[i-1]>=s) {   //a[i]+a[i+1]+...+a[m]>=S 
					if(res>m-i+1)          //子序列长度为m-i+1
						res=m-i+1;
					r=m-1;             //子序列长度为m-i+1存在解,再小一些试试(往左找)
				} else
					l=m+1;//子序列长度为m-i+1不存在解,大一些试试(往右找)
			}
		}
		printf("%d\n",res);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值