CS Course

 Little A has come to college and majored in Computer and Science. 

Today he has learned bit-operations in Algorithm Lessons, and he got a problem as homework. 

Here is the problem: 

You are giving n non-negative integers a1,a2,⋯,an, and some queries. 

A query only contains a positive integer p, which means you 
are asked to answer the result of bit-operations (and, or, xor) of all the integers except apap. 

Input

There are no more than 15 test cases. 

Each test case begins with two positive integers n and p 
in a line, indicate the number of positive integers and the number of queries. 

2≤n,q≤10^5 

Then n non-negative integers a1,a2,⋯,an follows in a line, 0≤ai≤10^9 for each i in range[1,n]. 

After that there are q positive integers p1,p2,⋯,pq in q lines, 1≤pi≤n for each i in range[1,q].

Output

For each query p, output three non-negative integers indicates the result of bit-operations(and, or, xor) of all non-negative integers except apap in a line. 

Sample Input

3 3
1 1 1
1
2
3

Sample Output

1 1 0
1 1 0
1 1 0

 位运算,前缀后缀

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=1e5+5;
typedef long long ll;
ll a[maxn],yu1[maxn],yu2[maxn],huo1[maxn],huo2[maxn];
int main(){
	int n,q;
	while(~scanf("%d%d",&n,&q)){
		int k=0;
		for(int i=1;i<=n;i++){
			scanf("%lld",&a[i]);
			k^=a[i];
		}	
	    yu1[1]=huo1[1]=a[1];
		for(int i=2;i<=n;i++){
			yu1[i]=yu1[i-1]&a[i];
			huo1[i]=huo1[i-1]|a[i];
		}
		yu2[n]=huo2[n]=a[n];
		for(int i=n-1;i>=1;i--){
			yu2[i]=yu2[i+1]&a[i];
			huo2[i]=huo2[i+1]|a[i];
		}			
		int p;
		for(int i=1;i<=q;i++){
			scanf("%d",&p);
			if(p==1) printf("%d %d %d\n",yu2[p+1],huo2[p+1],k^a[p]);
			else if(p==n) printf("%d %d %d\n",yu1[p-1],huo1[p-1],k^a[p]);
			else
			printf("%d %d %d\n",yu1[p-1]&yu2[p+1],huo1[p-1]|huo2[p+1],k^a[p]);
		}  
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值