hdu-5754 Life Winner Bo(混合博弈)

题目链接:https://cn.vjudge.net/problem/HDU-5754
Bo is a “Life Winner”.He likes playing chessboard games with his girlfriend G.

The size of the chessboard is N×M.The top left corner is numbered(1,1) and the lower right corner is numberd (N,M).

For each game,Bo and G take turns moving a chesspiece(Bo first).At first,the chesspiece is located at (1,1).And the winner is the person who first moves the chesspiece to (N,M).At one point,if the chess can’t be moved and it isn’t located at (N,M),they end in a draw.

In general,the chesspiece can only be moved right or down.Formally,suppose it is located at (x,y),it can be moved to the next point (x′,y′)only if x′≥xand y′≥y.Also it can’t be moved to the outside of chessboard.

Besides,There are four kinds of chess(They have movement rules respectively).

1.king.

2.rook(castle).

3.knight.

4.queen.

(The movement rule is as same as the chess.)

For each type of chess,you should find out that who will win the game if they both play in an optimal strategy.

Print the winner’s name(“B” or “G”) or “D” if nobody wins the game. InputIn the first line,there is a number T

as a case number.

In the next T lines,there are three numbers type,N and M.

“type” means the kind of the chess.

T≤1000,2≤N,M≤1000,1≤type≤4

OutputFor each question,print the answer.
Sample Input
4
1 5 5
2 5 5
3 5 5
4 5 5
Sample OutputG
G
D
B
题意:给你一个n∗m的棋盘,然后给你4种棋子,分别是:
1.王:能横着走,或者竖着走,或者斜着走,每次可以走1格
2.车:可以横着走或者竖着走,每次可以走无数格
3.马:走日字形
4.王后:可以横着走,或者竖着走,或者斜着走,每次可以走无数格
所有棋子在走的时候只能向右或向下走,不可后退,谁先走到(n,m)点,谁赢.

思路:
王:打表找规律(n和m只要有一个是偶数,就是先手赢)(打表见最底下)
车:nim博弈
马:找规律 ,规律见该博客 https://blog.csdn.net/helloiamclh/article/details/52039236
王后:威佐夫博弈 https://blog.csdn.net/qq_41311604/article/details/79980882

大神题解
https://blog.csdn.net/kopyh/article/details/52046436

#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
int main(){
 int T,q,n,m;
 scanf("%d",&T);
 while(T--){
  scanf("%d%d%d",&q,&n,&m);
  if(q==1){
   if(n%2==0||m%2==0) printf("B\n");
   else printf("G\n");
  }
  else if(q==2){
   int k=0;
   k^=(n-1);
   k^=(m-1);
   if(k==0) printf("G\n");
   else printf("B\n");
  }
  else if(q==3){
   if((n+m-2)%3!=0) printf("D\n");
   else{
    int r=(2*m-n-1)/3,c=(2*n-m-1)/3;
    if(abs(r-c)>=2) printf("D\n");
    else if(abs(r-c)==1) printf("B\n");
    else printf("G\n");
   }
  }
  else if(q==4){
   n--,m--;
   if(n<m) swap(n,m);
   int k=n-m;
   n=(int)(k*(1+sqrt(5.0))/2);
   if(n==m) printf("G\n");
   else printf("B\n");
  }
 }
 return 0;
}

王打表
在这里插入图片描述打表代码

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int sg[15][15];
int n,m;
int getsg(int x,int y){
 if(sg[x][y]!=-1) return sg[x][y];
 if(x==n&&y==m) return sg[x][y]=0;
 bool vis[15];
 memset(vis,0,sizeof(vis));
 for(int i=1;i<=3;i++){
  if(x+1<=n&&y<=m){
   sg[x+1][y]=getsg(x+1,y);
   vis[sg[x+1][y]]=true;
  }  
  if(x<=n&&y+1<=m){
   sg[x][y+1]=getsg(x,y+1);
   vis[sg[x][y+1]]=true;
  }  
  if(x+1<=n&&y+1<=m){
   sg[x+1][y+1]=getsg(x+1,y+1);
   vis[sg[x+1][y+1]]=true;
  } 
 }
 for(int i=0;;i++){
  if(!vis[i]) return sg[x][y]=i;
 }
}
int main(){
 printf("   ");
 for(int i=2;i<=10;i++){
  printf("%3d",i);
 }
 printf("\n");
 for(n=2;n<=10;n++){
  printf("%3d",n);
  for(m=2;m<=10;m++){
   memset(sg,-1,sizeof(sg));
   int a=getsg(1,1);
   printf("%3d",a);
  }
  printf("\n");
 }
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值