Little Sub and Enigma(思维模拟)

题目描述

Little Sub builds a naive Enigma machine of his own. It can only be used to encrypt/decrypt lower-case letters by giving each letter a unique corresponding lower-case letter. In order to ensure the accuracy, no contradiction or controversy is allowed in both the decryption and the encryption, which means all lower-case letters can only be decrypted/encrypted into a distinct lower-case letter.
Now we give you a string and its encrypted version. Please calculate all existing corresponding relationship which can be observed or deducted through the given information.

 

输入

The first line contains a string S, indicating the original message.
The second line contains a string T, indicating the encrypted version.
The length of S and T will be the same and not exceed 1000000.

 

输出

we use a string like ’x->y’ to indicate that letter x will be encrypted to letter y.
Please output all possible relationships in the given format in the alphabet order.
However, if there exists any contradiction in the given information, please just output Impossible in one line.

样例输入

banana
cdfdfd

样例输出

a->d
b->c
n->f

题意:原文与加密文一一对应,输出对应关系

注意:如果有25组已经确定了,那么剩下那组也就确定了,QAQ

 

#include<cstdio>
#include<cstring>
#include<vector>
using namespace std;
const int N=1e6+5;
char s[N],t[N];
vector<int> v[30];
int num[30];
int cnt=0;
int main(){
	scanf("%s%s",s,t);
	int len=strlen(s);
	bool flag=true;
	for(int i=0;i<len;i++){
		int a=s[i]-'a';
		int b=t[i]-'a';
		if(v[a].size()==0){
			v[a].push_back(b);
			num[b]++;
			cnt++;
		}
		if(v[a].size()!=0&&b!=v[a][0]){
			flag=false;
			break;
		}
	}
	if(flag){
		for(int i=0;i<26;i++){
			if(num[i]>1){
				flag=false;
				break;
			}
		}
	}
	if(flag){
		if(cnt==25){
			bool f=false;
			for(int i=0;i<26;i++){
				if(v[i].size()==0){
					for(int j=0;j<26;j++){
						if(num[j]==0){
							v[i].push_back(j);
							num[j]++;
							f=true;
							break;
						}
					}
				}
				if(f) break;
			}
		}
		for(int i=0;i<26;i++){
			if(v[i].size()>0){
				printf("%c->%c\n",'a'+i,'a'+v[i][0]);
			}
		}
	}
	else{
		printf("Impossible\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值