L1-064 估值一亿的AI核心代码 (20 分)

本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是:

  • 无论用户说什么,首先把对方说的话在一行中原样打印出来;
  • 消除原文中多余空格:把相邻单词间的多个空格换成 1 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉;
  • 把原文中所有大写英文字母变成小写,除了 I
  • 把原文中所有独立的 can youcould you 对应地换成 I canI could—— 这里“独立”是指被空格或标点符号分隔开的单词;
  • 把原文中所有独立的 I 和 me 换成 you
  • 把原文中所有的问号 ? 换成惊叹号 !
  • 在一行中输出替换后的句子作为 AI 的回答。

输入格式:

输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。

输出格式:

按题面要求输出,每个 AI 的回答前要加上 AI: 和一个空格。

输入样例:

6
Hello ?
 Good to chat   with you
can   you speak Chinese?
Really?
Could you show me 5
What Is this prime? I,don 't know

输出样例:

Hello ?
AI: hello!
 Good to chat   with you
AI: good to chat with you
can   you speak Chinese?
AI: I can speak chinese!
Really?
AI: really!
Could you show me 5
AI: I could show you 5
What Is this prime? I,don 't know
AI: what Is this prime! you,don't know

作者: 陈越

单位: 浙江大学

时间限制: 400 ms

内存限制: 64 MB

思路:无

如果有测试点没过可以看这个博客,说不定就知道哪里错了https://blog.csdn.net/dengkuomin/article/details/89053402

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<string>
#include<cstring>
#include<map>
#include<vector>
#include<set>
#include<list>
#include<stack>
#include<queue>
#include<sstream>
using namespace std;
typedef long long ll;
string s;
bool judge(char c){
	if(c>='a'&&c<='z') return false;
	if(c=='I') return false;
	if(c>='0'&&c<='9') return false;
	return true;
}
bool judge(string s){
	if(s[0]>='a'&&s[0]<='z') return false;
	if(s[0]=='I') return false;
	if(s[0]>='0'&&s[0]<='9') return false;
	return true;
}	
bool book[1005];
void solve(string s){
	memset(book,0,sizeof(book));
	int cnt=0;
	//大小写 
	 for(int i=0;i<s.size();i++){
	 	if(s[i]>='A'&&s[i]<='Z'&&s[i]!='I'){
	 		s[i]=(s[i]-'A'+'a');
		 }
	 }
	 
	 for(int i=0;i<s.size();i++){//判断符号后是否跟空格 ,true后面不跟 
		if(s[i]!=' '&&judge(s[i])) {
			cnt++;
			if(i+1<s.size()&&s[i+1]!=' ')book[cnt]=true;
			if(i==s.size()-1) book[cnt]=true;
		}	
	}

	 vector<string> v;
	 string str="";
	 for(int i=0;i<s.size();i++){
	 	if(s[i]!=' '){
	 		if(judge(s[i])){
	 			if(str!=""){
	 				v.push_back(str);		 
	 				str="";	
				 }
				 str=str+s[i];
				 v.push_back(str);
				 str="";
			 }
			 else{
			 	str=str+s[i];
			 }
		 }
		 else{
		 	if(str!=""){
		 		v.push_back(str);
		 		str="";
			 }
		 }
	 }
	 if(str!="") v.push_back(str);
	 str="";
	 
	 if(v.size()==0){
	 	cout<<"AI: "<<endl;
	 	return ;
	 } 
	 
	 for(int i=0;i<v.size();){
	 	if(v[i]=="I"||v[i]=="me") {
	 		v[i]="you";
	 		i++;
		 }
		 else if(i+1<v.size()&&v[i]=="could"&&v[i+1]=="you"){
		 	v[i]="I";
		 	v[i+1]="could";
		 	i+=2;
		 }
		 else if(i+1<v.size()&&v[i]=="can"&&v[i+1]=="you"){
		 	v[i]="I";
		 	v[i+1]="can";
		 	i+=2;
		 }
		 else i++;
	 } 

	 cnt=0;
	 str=v[0];
	 if(judge(v[0])){
	 	++cnt;
	 	if(!book[cnt]) str=str+" ";
	 }
	 for(int i=1;i<v.size();i++){
	     if(judge(v[i-1])){
	     	if(judge(v[i])){
	     		cnt++;
	     		if(!book[cnt]){
	     			if(i+1<v.size()&&judge(v[i+1])) str=str+v[i];
		 			else str=str+v[i]+" ";
				 }
	     		else str=str+v[i];
			 }
			 else str=str+v[i];
		 }
		 else{
		 	if(judge(v[i])){
		 		cnt++;
		 		if(!book[cnt]) {
		 			if(i+1<v.size()&&judge(v[i+1])) str=str+v[i];
		 			else str=str+v[i]+" ";
				 }
		 		else str=str+v[i];
			 }
			 else str=str+" "+v[i];
		 }
	 }
	 for(int i=0;i<str.size();i++){
	 	if(str[i]=='?') str[i]='!';
	 }
	 cout<<"AI: "<<str<<endl;
}
int main(){
    int T;
    scanf("%d",&T);
    getchar();
	while(T--){
		getline(cin,s);
		cout<<s<<endl;
		solve(s);
	} 
	return 0;
}

 

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值