hdu2444——The Accomodation of Students(判断二分图+匈牙利算法)

Problem Description
There are a group of students. Some of them may know each other, while others don’t. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don’t know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.

Input
For each data set:
The first line gives two integers, n and m(1n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

Output
If these students cannot be divided into two groups, print “No”. Otherwise, print the maximum number of pairs that can be arranged in those rooms.

Sample Input
4 4
1 2
1 3
1 4
2 3
6 5
1 2
1 3
1 4
2 5
3 6

Sample Output
No
3

给定m对人,他们互相认识,求这些人能不能成为二分图?如果能,求最大匹配
用BFS判断二分图,将每对点分为0或1,如果所有点对都满足这个规律,那就是二分图,然后再用匈牙利算法,因为是求多少对人,所以最后要除以2

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
//#include <map>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 205
#define Mod 10001
using namespace std;
bool vis[MAXN];
int n,m;
int mp[MAXN][MAXN],pre[MAXN];  //匹配路径;
int find(int cur)
{
    for(int i=1; i<=n; ++i)
    {
        if(!vis[i]&&mp[cur][i])
        {
            vis[i] = true;
            if(pre[i] == 0 || find(pre[i]))
            {
                pre[i]=cur;
                return 1;
            }
        }
    }
    return 0;
}
int judge[MAXN];
bool bfs()
{
    memset(judge,-1,sizeof(judge));
    queue<int> q;
    q.push(1);
    judge[1]=0;
    while(!q.empty())
    {
        int v=q.front();
        q.pop();
        for(int i=1;i<=n;++i)
        {
            if(mp[v][i])
            {
                if(judge[i]==-1)
                {
                    judge[i]=(judge[v]+1)%2;
                    q.push(i);
                }
                else
                {
                    if(judge[i]==judge[v])
                        return false;
                }
            }
        }
    }
    return true;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        memset(mp,0,sizeof(mp));
        memset(pre,0,sizeof(pre));
        int a,b;
        for(int i=0;i<m;++i)
        {
            scanf("%d%d",&a,&b);
            mp[a][b]=1;
            mp[b][a]=1;
        }
        if(!bfs())
        {
            puts("No");
            continue;
        }
        int ans=0;
        for(int i=1;i<=n;++i)
        {
            memset(vis,0,sizeof(vis));
            if(find(i))
                ans++;
        }
        printf("%d\n",ans/2);
    }
    return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值