PAT-1090-树的遍历

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:
Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10的5次 ), the total number of the members in the supply chain (and hence they are numbered from 0 to N−1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number S​i is the index of the supplier for ,the i-th member. S ​root for the root supplier is defined to be −1. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 10的​10次​​ .

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2

谷歌中文翻译:

供应链是零售商(零售商),分销商(经销商)和供应商(供应商)的网络,每个人都参与将产品从供应商转移到客户的过程。

从一个根供应商开始,链中的每个人都以一个价格P从一个供应商那里购买产品,然后以比P高出r%的价格出售或分发它们。假定供应链中的每个成员只有一个供应商,除了根供应商,并且没有供应周期。

现在有了供应链,您应该告诉我们一些零售商可以期望的最高价格。

输入规格:
每个输入文件包含一个测试用例。对于每种情况,第一行包含三个正数:N(≤10的5次),供应链中成员的总数(因此从0到N-1编号); P,根供应商给出的价格; r,每个分销商或零售商的价格上涨百分比。然后下一行包含N个数字,每个数字S i是第i个成员的供应商的索引。根供应商的S根定义为-1。一行中的所有数字都用空格分隔。

输出规格:
对于每个测试用例,在一行中打印我们可以预期的某些零售商的最高价格,精确到小数点后2位,以及以最高价格出售的零售商数量。两个数字之间必须有一个空格。保证价格不会超过10的10次。

思路:
和下面这道我写过的类似
经销商供销商问题

#include<bits/stdc++.h>
using namespace std;

const int MAX_N = 100005;
int n;
double p, r;
vector<int> v[MAX_N];
int sup;	//供应商 
int maxdepth = 0;
int maxnum = 0;
double profit;
void init() {
	cin >> n >> p >> r;
	int tem;
	for(int i = 0; i < n; i++) {
		cin >> tem;
		if(tem == -1)
			sup = i;
		else 
			v[tem].push_back(i);
	}
}

void dfs(int index, int depth) {
	if(v[index].size() == 0) {
		if(maxdepth == depth) {
			maxnum++;
		}
		if(maxdepth < depth) {
			maxdepth = depth;
			maxnum = 1;
		}
		return ;
	}
	for(int i = 0; i < v[index].size(); i++) {
		dfs(v[index][i], depth + 1);
	}
}

int main() {
	init();
	dfs(sup, 0);
	printf("%.2f %d", p * pow(1 + r/100, maxdepth), maxnum);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值