PAT-1004-树的遍历

1004 Counting Leaves
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output “0 1” in a line.
Sample Input:

2 1
01 1 02

Sample Output:

0 1

谷歌中文翻译:
家庭等级通常由谱系树表示。您的工作是计算没有孩子的家庭成员。

输入值

每个输入文件包含一个测试用例。每种情况都从包含0 <N <100(树中的节点数)和M(<N)(非叶节点数)的行开始。然后是M行,每行的格式为:

ID K ID[1] ID[2] … ID[K]

其中ID是代表给定非叶节点的两位数字,K是其子代号,其后是其子代的两位ID序列。为了简单起见,让我们将根ID固定为01。

输出量

对于每个测试用例,应该从根开始计算每个资历级别中没有孩子的家庭成员。数字必须成行打印,并用空格隔开,并且每行末尾不得有多余的空格。

该示例案例表示一棵只有2个节点的树,其中01是根,而02是其唯一的子节点。因此,在根01级别上,存在0个叶节点;在下一个级别上,有1个叶节点。然后,我们应该在一行中输出“ 0 1”。

思路:
刚开始想,既然是树,想建树的数据结构来做,后来看了柳神的思路发现不需要这么麻烦,因为这里没有涉及到结点的点权等概念,用一个vector足以。
既然是找叶子结点,那就遍历吧。深搜广搜层次搜都行,搜完完事,这题的案例数据量不大。

#include<bits/stdc++.h>
using namespace std;
const int MAX_N = 510;

vector<int> v[MAX_N];
int n, m;
int node, t;  
int temp;
int maxdep = -1;
int book[MAX_N];
void init() {
	cin >> n >> m;
	for(int i = 0; i < m; i++) {
		cin >> node >> t; 
		for(int j = 0; j < t; j++) {
			cin >> temp;
			v[node].push_back(temp);
		}
	}
}

void dfs(int index, int dep) {
	//找到叶结点 
	if(v[index].size() == 0) {
		book[dep]++;
		maxdep = max(dep, maxdep);
		return ;
	}
	//遍历 
	for(int i = 0; i < v[index].size(); i++) {
		dfs(v[index][i], dep + 1);
	}
}


int main() {
	init();
	dfs(1, 0); //根节点出发 此时dep为0 
	cout << book[0];
	for(int i = 1; i <= maxdep; i++) {
		cout << " " << book[i];
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值