PAT-1106-树的遍历

1106 Lowest Price in Supply Chain
A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)– everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=10的5次), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N-1, and the root supplier’s ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] … ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. Kj being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 10的10次.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0

Sample Output:

1.8362 2

谷歌中文翻译:
供应链是零售商(零售商),分销商(经销商)和供应商(供应商)的网络,每个人都参与将产品从供应商转移到客户的过程。

从一个根供应商开始,连锁店中的每个人都以价格P向某供应商购买产品,并以比P高出r%的价格出售或分发产品。只有零售商才能面对顾客。假设供应链中的每个成员除根供应商外都只有一个供应商,并且没有供应周期。

现在有了供应链,您应该告诉客户一些零售商可以期望的最低价格。

输入规格:

每个输入文件包含一个测试用例。对于每种情况,第一行包含三个正数:N(<= 10的5次),供应链中成员的总数(因此,其ID的编号从0到N-1,根供应商的编号ID为0); P,根供应商给出的价格; r,每个分销商或零售商的价格上涨百分比。然后N行,每行以以下格式描述分销商或零售商:

Ki ID [1] ID [2]…ID [Ki]

在第i行中,Ki是从供应商i接收产品的分销商或零售商的总数,然后是这些分销商或零售商的ID。 Kj为0表示第j个成员是零售商。一行中的所有数字都用空格分隔。

输出规格:

对于每个测试用例,一行打印出我们可以预期的某些零售商的最低价格,精确到小数点后4位,以及以最低价格出售的零售商数量。两个数字之间必须有一个空格。保证所有价格都不会超过10的10次。

思路:
这题和PAT-1090思路一致,将求最大改成求最小,并更改输入即可。

#include<bits/stdc++.h>
using namespace std;

const int MAX_N = 100005;
int n;
double p, r;
vector<int> v[MAX_N];
int mindepth = 100000000;
int minnum = 1;
double profit;
void init() {
	cin >> n >> p >> r;
	int tem;
	int k;
	for(int i = 0; i < n; i++) {
		cin >> k;
		for(int j = 0; j < k; j++) {
			cin >> tem;
			v[i].push_back(tem);
		}
	}
}

void dfs(int index, int depth) {
	if(mindepth < depth)
		return ;
	if(v[index].size() == 0) {
		if(mindepth == depth) {
			minnum++;
		}
		else if(mindepth > depth) {
			mindepth = depth;
			minnum = 1;
		}
		return ;
	}
	for(int i = 0; i < v[index].size(); i++) {
		dfs(v[index][i], depth + 1);
	}
}

int main() {
	init();
	dfs(0, 0);
	printf("%.4f %d", p * pow(1 + r/100, mindepth), minnum);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值