区间和,离散化

假定有一个无限长的数轴,数轴上每个坐标上的数都是 0。
现在,我们首先进行 n 次操作,每次操作将某一位置 x 上的数加 c。
接下来,进行 m 次询问,每个询问包含两个整数 l 和 r,你需要求出在区间 [l,r] 之间的所有数的和。
输入格式
第一行包含两个整数 n 和 m。
接下来 n 行,每行包含两个整数 x 和 c。
再接下来 m 行,每行包含两个整数 l 和 r。
输出格式
共 m 行,每行输出一个询问中所求的区间内数字和。
数据范围
−109≤x≤109,
1≤n,m≤105,
−109≤l≤r≤109,
−10000≤c≤10000
输入样例:
3 3
1 2
3 6
7 5
1 3
4 6
7 8
输出样例:
8
0
5

离散化:
映射 + 去重复的值
//unique(alls.begin(), alls.end() :将该容器中所有元素去重;
//alls.erase(unique(alls.begin(), alls.end()), alls.end());//去掉重复元素

vector<int> alls; //存储所有离散化的值
sort(alls.begin(), alls.end());//将所有值排序
alls.erase(unique(alls.begin(), alls.end()), alls.end());//去掉重复元素

//二分求出x对应的离散化的值
int find(int x) //找到第一个大于等于x的位置
{
	int l = 0, r = alls.size() - 1;
	while(l < r)
	{
		int mid = l + r >> 1;
		if(alls[mid] >= x) r = mid;
		else l  = mid + 1;
	}
	return r  + 1; //映射到1,2,...n;  不加1从0映射,具体问题具体分析
}
#include<iostream>
#include<vector>
#include<algorithm>

using namespace std;

typedef pair<int,int>PII;//定义pair 类型
const int N = 3e5 + 10;//根据n,m的范围定义上界(查询n+m次+坐标和)

vector<int> alls;//需要映射的数据
vector<PII> add;//需要插入的数据
vector<PII> query;//需要询问的数据
int a[N],s[N];//存储坐标的插入值//存储数组a的前缀和
int n,m;
//返回输入的坐标的离散化(包括边界-l/r和位置-x)——通过二分查找实现
int find(int x)
{
    int l = 0, r = alls.size() - 1;
    while(l < r)
    {
        int mid = l + r >> 1;
        if(alls[mid] >= x) r = mid;
        else
            l = mid + 1;
    }
    return r + 1;
}
int main()
{
    cin>>n>>m;
    //对需要离散化的x添加和拆入x,c;
    for(int i = 0; i < n; i ++)
    {
        int x, c;
        cin>>x>>c;
        alls.push_back(x);
        add.push_back({x,c});
    }
    //对需要离散化的端点添加l,r。插入询问范围。
    for(int i = 0; i < m ; i ++)
    {
        int l, r;
        cin>>l >>r;
        query.push_back({l,r});
        alls.push_back(l);
        alls.push_back(r);
    }
    //排序,去重
    sort(alls.begin(),alls.end());
    alls.erase(unique(alls.begin(),alls.end()),alls.end());
    //执行前n次插入操作
    for(auto item : add)
    {
        int x = find(item.first);
        a[x] += item.second;
    }
    //求前缀和
    for(int i = 1; i <= alls.size();i ++) s[i] = s[i - 1] + a[i];
    //处理m次询问操作,通过前缀和算法实现范围求和。
    for(auto item : query)
    {
        int l = find(item.first), r = find(item.second);
        cout<<s[r] - s[l - 1]<<endl;
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

子非鱼¤

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值