Problem Description
大家应该都见过那种九键的手机键盘,键盘上各字母的分布如下图所示。
当我们用这种键盘输入字母的时候,对于有些字母,往往会需要按多次键才能输入。
比如:a, b, c 都在“2”键上,输入 a 只需要按一次,而输入 c 需要连续按三次。
连续输入多个字母的规则如下:
1、如果前后两个字母不在同一个按键上,则可在输入前一个字母之后直接输入下一个字母,如:ad 需要按两次键盘,kz 需要按 6 次。
2、如果前后两个字母在同一个按键上,则输入完前一个字母之后需要等待一段时间才能输入下一个字母,如 ac,在输入完 a 之后,需要等一会儿才能输入 c。
现在假设每按一次键盘需要花费一个时间段,等待时间需要花费两个时间段。
现在给出一串只包含小写英文字母的字符串,计算出输入它所需要花费的时间。
Input
输入包含多组测试数据,对于每组测试数据:
输入为一行只包含小写字母的字符串,字符串长度不超过100。
Output
对于每组测试数据,输出需要花费的时间。
Sample Input
bob
www
Sample Output
7
7
import java.util.Scanner;
public class Main {
public static int sign(char x)
{
if(x >= 'a' && x <= 'c')
return 2;
else if(x >= 'd' && x <= 'f')
return 3;
else if(x >= 'g' && x <= 'i')
return 4;
else if(x >= 'j' && x <= 'l')
return 5;
else if(x >= 'm' && x <= 'o')
return 6;
else if(x >= 'p' && x <= 's')
return 7;
else if(x >= 't' && x <= 'v')
return 8;
else
return 9;
}
public static int time(char x)
{
int y = 0;
if(x == 'a' || x == 'd' || x == 'g' || x == 'j' || x == 'm' || x == 'p' || x == 't' || x == 'w')
{
y = 1;
}
else if(x == 'b' || x == 'e' || x == 'h' || x == 'k' || x == 'n' || x == 'q' || x == 'u' || x == 'x')
{
y = 2;
}
else if(x == 'c' || x == 'f' || x == 'i' || x == 'l' || x == 'o' || x == 'r' || x == 'v' || x == 'y')
{
y = 3;
}
else if(x == 's' || x == 'z')
{
y = 4;
}
return y;
}
public static void main(String args[]) {
Scanner in = new Scanner(System.in);
String s;
int i, t;
while(in.hasNextLine())
{
t = 0;
s = in.nextLine();
char si[] = s.toCharArray();
for(i = 0; i < si.length; i++)
{
t += time(si[i]);
}
for(i = 1; i < si.length; i++)
{
if(sign(si[i]) == sign(si[i - 1]))
{
t += 2;
}
}
System.out.println(t);
}
in.close();
}
}